Debcheck

 

Back to QA

Debcheck - bullseye
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster stretch jessie

Problems for source package newt

Current Source Version: 0.52.21-3
Current Maintainer: Alastair McKinstry <mckinstry@debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:newt

BuildDepends

Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mipsel. Package newt does not exist on mipsel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armel. Package newt does not exist on armel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on ppc64el. Package newt does not exist on ppc64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on arm64. Package newt does not exist on arm64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mips64el. Package newt does not exist on mips64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on s390x. Package newt does not exist on s390x.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on i386. Package newt does not exist on i386.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armhf. Package newt does not exist on armhf.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on amd64. Package newt does not exist on amd64.

Malformed Build-Depends

Package declares a build time dependency on 'python3-all-dev:any ' which is broken Syntax.
Package declares a build time dependency on 'dh-python ' which is broken Syntax.
Package declares a build time dependency on 'libpython3-all-dev ' which is broken Syntax.

Binary Package: whiptail (Version: 0.52.21-3)

BTS entry: https://bugs.debian.org/whiptail

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is important and has a Depends on libc6 (>= 2.17) which is optional on ppc64el.
Package is important and has a Depends on libc6 (>= 2.17) which is optional on arm64.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on amd64.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on mips64el.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on s390x.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on armhf.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on i386.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on arm64.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on ppc64el.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on mipsel.
Package is important and has a Depends on libpopt0 (>= 1.14) which is optional on armel.
Package is important and has a Depends on libc6 (>= 2.4) which is optional on s390x.
Package is important and has a Depends on libc6 (>= 2.4) which is optional on mips64el.
Package is important and has a Depends on libc6 (>= 2.4) which is optional on mipsel.
Package is important and has a Depends on libc6 (>= 2.4) which is optional on armel.
Package is important and has a Depends on libc6 (>= 2.4) which is optional on armhf.
Package is important and has a Depends on libc6 (>= 2.4) which is optional on i386.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on mipsel.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on armel.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on arm64.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on ppc64el.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on mips64el.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on s390x.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on i386.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on armhf.
Package is important and has a Depends on libslang2 (>= 2.2.4) which is optional on amd64.
Package is important and has a Depends on libc6 (>= 2.14) which is optional on amd64.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on amd64.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on armhf.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on i386.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on s390x.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on mips64el.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on ppc64el.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on arm64.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on armel.
Package is important and has a Depends on libnewt0.52 (>= 0.52.21) which is optional on mipsel.


Last updated: Sun Oct 20 15:27:13 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS