Debcheck

 

Back to QA

Debcheck - bullseye
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package rust-grep-printer

Current Source Version: 0.1.3-2
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-grep-printer

Malformed Build-Depends

Package declares a build time dependency on 'librust-grep-searcher-0.1+default-dev (>= 0.1.4-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-base64-0.11+default-dev <!nocheck> | librust-base64-0.10+default-dev <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'rustc:native <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'cargo:native <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-termcolor-1+default-dev (>= 1.0.4-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-serde-derive-1+default-dev (>= 1.0.77-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-serde-json-1+default-dev (>= 1.0.27-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-grep-matcher-0.1+default-dev (>= 0.1.2-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-bstr-0.2+default-dev <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-serde-1+default-dev (>= 1.0.77-~~) <!nocheck>' which is broken Syntax.

Binary Package: librust-grep-printer+base64-dev (Version: 0.1.3-2)

BTS entry: https://bugs.debian.org/librust-grep-printer+base64-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on ppc64el. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on arm64. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on mips64el. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on armhf. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on armel. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on s390x. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on i386. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on mipsel. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on amd64. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.

Binary Package: librust-grep-printer+serde1-dev (Version: 0.1.3-2)

BTS entry: https://bugs.debian.org/librust-grep-printer+serde1-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on mipsel. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on amd64. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on s390x. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on i386. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on armel. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on armhf. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on arm64. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on ppc64el. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.
Package has a Depends on librust-base64-0.11+default-dev which cannot be satisfied on mips64el. At least one of librust-base64-0.11+default-dev | librust-base64-0.10+default-dev can be satisfied however.


Last updated: Wed Feb 19 15:26:02 2020

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS