Debcheck

 

Back to QA

Debcheck - bullseye
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye

Problems for source package rust-parking-lot-core-0.4

Current Source Version: 0.4.0-4
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-parking-lot-core-0.4

Half Broken Build-Depends

(not necessarily bugs)

Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on i386. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on armhf. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on s390x. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on mips64el. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on amd64. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on arm64. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on armel. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on ppc64el. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package declares a build time dependency on librust-smallvec-0+default-dev (>= 0.6-~~) <!nocheck> which cannot be satisfied on mipsel. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.

Malformed Build-Depends

Package declares a build time dependency on 'rustc:native <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'cargo:native <!nocheck>' which is broken Syntax.

Binary Package: librust-parking-lot-core-0.4-dev (Version: 0.4.0-4)

BTS entry: https://bugs.debian.org/librust-parking-lot-core-0.4-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on s390x. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on armhf. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on i386. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on armel. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on ppc64el. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on mipsel. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on mips64el. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on amd64. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.
Package has a Depends on librust-smallvec-0+default-dev (>= 0.6-~~) which cannot be satisfied on arm64. At least one of librust-smallvec-1+default-dev | librust-smallvec-0+default-dev (>= 0.6-~~) can be satisfied however.

Binary Package: librust-parking-lot-core-0.4+deadlock-detection-dev (Version: 0.4.0-4)

BTS entry: https://bugs.debian.org/librust-parking-lot-core-0.4+deadlock-detection-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on s390x. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on armhf. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on i386. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on armel. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on ppc64el. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on mipsel. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on arm64. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on mips64el. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on amd64. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.

Binary Package: librust-parking-lot-core-0.4+petgraph-dev (Version: 0.4.0-4)

BTS entry: https://bugs.debian.org/librust-parking-lot-core-0.4+petgraph-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on arm64. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on amd64. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on mips64el. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on mipsel. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on ppc64el. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on armel. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on armhf. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on i386. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.
Package has a Depends on librust-petgraph-0.4+default-dev (>= 0.4.5-~~) which cannot be satisfied on s390x. At least one of librust-petgraph-0.5+default-dev | librust-petgraph-0.4+default-dev (>= 0.4.5-~~) can be satisfied however.


Last updated: Wed Dec 2 15:26:06 2020

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS