Debcheck

 

Back to QA

Debcheck - buster
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: experimental sid bullseye buster stretch

Problems for source package nvidia-cuda-toolkit

Current Source Version: 9.2.148-7
Current Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Section: non-free
BTS entry: https://bugs.debian.org/src:nvidia-cuda-toolkit

BuildDepends

Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on amd64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on ppc64el.

Binary Package: nvidia-opencl-dev (Version: 9.2.148-7)

BTS entry: https://bugs.debian.org/nvidia-opencl-dev

Relationships

Package has a Recommends on nvidia-opencl-icd which cannot be satisfied on ppc64el.

Binary Package: nvidia-cuda-doc (Version: 9.2.148-7)

BTS entry: https://bugs.debian.org/nvidia-cuda-doc

Relationships

Package has a Depends on libjs-html5shiv which cannot be satisfied on i386.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mips64el.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mips.
Package has a Depends on libjs-html5shiv which cannot be satisfied on s390x.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mipsel.
Package has a Depends on libjs-html5shiv which cannot be satisfied on armel.
Package has a Depends on libjs-html5shiv which cannot be satisfied on arm64.
Package has a Depends on libjs-html5shiv which cannot be satisfied on amd64.
Package has a Depends on libjs-html5shiv which cannot be satisfied on armhf.
Package has a Depends on libjs-html5shiv which cannot be satisfied on ppc64el.

Binary Package: nvidia-cuda-dev (Version: 9.2.148-7)

BTS entry: https://bugs.debian.org/nvidia-cuda-dev

Relationships

Package has a Recommends on libnvcuvid1 which cannot be satisfied on ppc64el.

Half Broken Relationships

(not necessarily bugs)

Package has a Recommends on libcuda-9.2-1 which cannot be satisfied on ppc64el. At least one of libcuda1 (>= 396.37) | libcuda-9.2-1 | no-libcuda1 can be satisfied however.
Package has a Recommends on libcuda1 (>= 396.37) which cannot be satisfied on ppc64el. At least one of libcuda1 (>= 396.37) | libcuda-9.2-1 | no-libcuda1 can be satisfied however.

Binary Package: nvidia-cuda-toolkit (Version: 9.2.148-7)

BTS entry: https://bugs.debian.org/nvidia-cuda-toolkit

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on gcc-6 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-6 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-5 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-5 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.9 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.9 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:6~) which cannot be satisfied on ppc64el. clang 1:7.0-47 is available. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:6~) which cannot be satisfied on amd64. clang 1:7.0-47 is available. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.8 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.8 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on ppc64el. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on amd64. At least one of gcc-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on g++-6 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-6 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.9 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.9 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:6~) which cannot be satisfied on amd64. clang 1:7.0-47 is available. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:6~) which cannot be satisfied on ppc64el. clang 1:7.0-47 is available. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-5 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-5 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.8 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.8 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on ppc64el. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on amd64. At least one of g++-7 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:6~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.

Binary Package: libthrust-dev (Version: 1.9.2~9.2.148-7)

BTS entry: https://bugs.debian.org/libthrust-dev

Relationships

Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on mipsel.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on s390x.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on mips64el.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on mips.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on i386.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on armhf.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on arm64.
Package has a Suggests on nvidia-cuda-toolkit which cannot be satisfied on armel.

Binary Package: nvidia-openjdk-8-jre (Version: 9.+8u77~9.2.148-7)

BTS entry: https://bugs.debian.org/nvidia-openjdk-8-jre

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Depends on libgl1 which is extra on amd64.

Binary Package: libcuinj64-9.2 (Version: 9.2.148-7)

BTS entry: https://bugs.debian.org/libcuinj64-9.2

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on libcuda-9.2-1 which cannot be satisfied on ppc64el. At least one of libcuda1 (>= 396.37) | libcuda-9.2-1 | no-libcuda1 can be satisfied however.
Package has a Depends on libcuda1 (>= 396.37) which cannot be satisfied on ppc64el. At least one of libcuda1 (>= 396.37) | libcuda-9.2-1 | no-libcuda1 can be satisfied however.


Last updated: Tue Oct 22 15:29:13 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS