Debcheck

 

Back to QA

Debcheck - buster
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster stretch

Problems for source package starpu-contrib

Current Source Version: 1.2.6+dfsg-6
Current Maintainer: Samuel Thibault <sthibault@debian.org>
Section: contrib
BTS entry: https://bugs.debian.org/src:starpu-contrib

BuildDepends

Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on armel. Package starpu-contrib does not exist on armel.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on s390x. Package starpu-contrib does not exist on s390x.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on i386. Package starpu-contrib does not exist on i386.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on mips64el. Package starpu-contrib does not exist on mips64el.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on arm64. Package starpu-contrib does not exist on arm64.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on armhf. Package starpu-contrib does not exist on armhf.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on mipsel. Package starpu-contrib does not exist on mipsel.
Package declares a build time dependency on nvidia-cuda-toolkit (>= 9.2) which cannot be satisfied on mips. Package starpu-contrib does not exist on mips.

Binary Package: libstarpu-contrib-dev (Version: 1.2.6+dfsg-6)

BTS entry: https://bugs.debian.org/libstarpu-contrib-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on libstarpu-contrib-any-1.2-5 which cannot be satisfied on amd64. At least one of libstarpu-contrib-1.2-5 (= 1.2.6+dfsg-6) | libstarpu-contrib-any-1.2-5 can be satisfied however.
Package has a Depends on libsocl-contrib-any-1.2-0 which cannot be satisfied on amd64. At least one of libsocl-contrib-1.2-0 (= 1.2.6+dfsg-6) | libsocl-contrib-any-1.2-0 can be satisfied however.
Package has a Depends on libstarpu-contrib-anympi-1.2-3 which cannot be satisfied on amd64. At least one of libstarpu-contribmpi-1.2-3 (= 1.2.6+dfsg-6) | libstarpu-contrib-anympi-1.2-3 can be satisfied however.
Package has a Depends on libstarpu-contrib-anyfft-1.2-0 which cannot be satisfied on amd64. At least one of libstarpu-contribfft-1.2-0 (= 1.2.6+dfsg-6) | libstarpu-contrib-anyfft-1.2-0 can be satisfied however.

Binary Package: starpu-contrib-examples (Version: 1.2.6+dfsg-6)

BTS entry: https://bugs.debian.org/starpu-contrib-examples

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Depends on libgl1 which is extra on amd64.


Last updated: Wed Oct 16 15:29:11 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS