Debcheck

 

Back to QA

Debcheck - experimental
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: experimental sid trixie bookworm bullseye buster

Problems for source package nodejs

Current Source Version: 20.10.0+dfsg-1
Current Maintainer: Debian Javascript Maintainers <pkg-javascript-devel@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:nodejs

BuildDepends

Package declares a build time dependency on vfpv2-support [armel] <!nocheck> which cannot be satisfied on armel.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on ppc64el.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on arm64.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on armel.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on s390x.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on amd64.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on i386.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on mips64el.
Package declares a build time dependency on pkg-js-tools (>= 0.8.2~) <!nocheck> which cannot be satisfied on armhf.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on arm64.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on ppc64el.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on s390x.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on armel.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on i386.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on amd64.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on mips64el.
Package declares a build time dependency on debhelper-compat (= 13) which cannot be satisfied on armhf.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on i386.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on amd64.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on mips64el.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on armhf.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on ppc64el.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on arm64.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on armel.
Package declares a build time dependency on procps <!nocheck> which cannot be satisfied on s390x.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on amd64.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on i386.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on armhf.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on mips64el.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on arm64.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on ppc64el.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on s390x.
Package declares a build time dependency on libbrotli-dev which cannot be satisfied on armel.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on ppc64el.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on arm64.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on armel.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on s390x.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on i386.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on amd64.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on armhf.
Package declares a build time dependency on node-acorn (>= 6.2.1~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on mips64el.
Package declares a build time dependency on ca-certificates which cannot be satisfied on arm64.
Package declares a build time dependency on ca-certificates which cannot be satisfied on ppc64el.
Package declares a build time dependency on ca-certificates which cannot be satisfied on s390x.
Package declares a build time dependency on ca-certificates which cannot be satisfied on armel.
Package declares a build time dependency on ca-certificates which cannot be satisfied on amd64.
Package declares a build time dependency on ca-certificates which cannot be satisfied on i386.
Package declares a build time dependency on ca-certificates which cannot be satisfied on mips64el.
Package declares a build time dependency on ca-certificates which cannot be satisfied on armhf.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on s390x.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on armel.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on arm64.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on ppc64el.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on armhf.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on mips64el.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on amd64.
Package declares a build time dependency on libuv1-dev (>= 1.43.0~) which cannot be satisfied on i386.
Package declares a build time dependency on python3-distutils which cannot be satisfied on armel.
Package declares a build time dependency on python3-distutils which cannot be satisfied on s390x.
Package declares a build time dependency on python3-distutils which cannot be satisfied on ppc64el.
Package declares a build time dependency on python3-distutils which cannot be satisfied on arm64.
Package declares a build time dependency on python3-distutils which cannot be satisfied on mips64el.
Package declares a build time dependency on python3-distutils which cannot be satisfied on armhf.
Package declares a build time dependency on python3-distutils which cannot be satisfied on amd64.
Package declares a build time dependency on python3-distutils which cannot be satisfied on i386.
Package declares a build time dependency on jq which cannot be satisfied on amd64.
Package declares a build time dependency on jq which cannot be satisfied on i386.
Package declares a build time dependency on jq which cannot be satisfied on mips64el.
Package declares a build time dependency on jq which cannot be satisfied on armhf.
Package declares a build time dependency on jq which cannot be satisfied on ppc64el.
Package declares a build time dependency on jq which cannot be satisfied on arm64.
Package declares a build time dependency on jq which cannot be satisfied on armel.
Package declares a build time dependency on jq which cannot be satisfied on s390x.
Package declares a build time dependency on bash-completion which cannot be satisfied on armhf.
Package declares a build time dependency on bash-completion which cannot be satisfied on mips64el.
Package declares a build time dependency on bash-completion which cannot be satisfied on i386.
Package declares a build time dependency on bash-completion which cannot be satisfied on amd64.
Package declares a build time dependency on bash-completion which cannot be satisfied on armel.
Package declares a build time dependency on bash-completion which cannot be satisfied on s390x.
Package declares a build time dependency on bash-completion which cannot be satisfied on ppc64el.
Package declares a build time dependency on bash-completion which cannot be satisfied on arm64.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on i386.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on amd64.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on armhf.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on mips64el.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on ppc64el.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on arm64.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on armel.
Package declares a build time dependency on libhttp-parser-dev (>= 2.9.2~) which cannot be satisfied on s390x.
Package declares a build time dependency on armv6k-support [armel] <!nocheck> which cannot be satisfied on armel.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on armhf.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on mips64el.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on i386.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on amd64.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on s390x.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on armel.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on arm64.
Package declares a build time dependency on libnghttp2-dev (>= 1.41.0~) which cannot be satisfied on ppc64el.
Package declares a build time dependency on sse2-support [i386] <!nocheck> which cannot be satisfied on i386.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on ppc64el.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on arm64.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on armel.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on s390x.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on amd64.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on i386.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on mips64el.
Package declares a build time dependency on dh-buildinfo which cannot be satisfied on armhf.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on ppc64el.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on arm64.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on armel.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on s390x.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on amd64.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on i386.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on armhf.
Package declares a build time dependency on node-undici (>= 5.0.0~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on mips64el.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on amd64.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on i386.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on armhf.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on mips64el.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on ppc64el.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on arm64.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on armel.
Package declares a build time dependency on node-cjs-module-lexer (>= 1.2.2~) <!pkg.nodejs.nobuiltin> which cannot be satisfied on s390x.

Malformed Build-Depends

Package declares a build time dependency on 'libbrotli-dev:native' which is broken Syntax.
Package declares a build time dependency on 'libc-ares-dev:native' which is broken Syntax.
Package declares a build time dependency on 'libnghttp2-dev:native' which is broken Syntax.
Package declares a build time dependency on 'libicu-dev:native' which is broken Syntax.
Package declares a build time dependency on 'libuv1-dev:native' which is broken Syntax.
Package declares a build time dependency on 'zlib1g-dev:native' which is broken Syntax.
Package declares a build time dependency on 'libssl-dev:native' which is broken Syntax.
Package declares a build time dependency on 'python3:native' which is broken Syntax.

Binary Package: nodejs (Version: 20.10.0+dfsg-1)

BTS entry: https://bugs.debian.org/nodejs

Relationships

Package has a Depends on armv6k-support which cannot be satisfied on armel.
Package has a Depends on vfpv2-support which cannot be satisfied on armel.
Package has a Depends on sse2-support which cannot be satisfied on i386.
Package has a Recommends on ca-certificates which cannot be satisfied on s390x.
Package has a Recommends on ca-certificates which cannot be satisfied on armel.
Package has a Recommends on ca-certificates which cannot be satisfied on arm64.
Package has a Recommends on ca-certificates which cannot be satisfied on ppc64el.
Package has a Recommends on ca-certificates which cannot be satisfied on mips64el.
Package has a Recommends on ca-certificates which cannot be satisfied on armhf.
Package has a Recommends on ca-certificates which cannot be satisfied on amd64.
Package has a Recommends on ca-certificates which cannot be satisfied on i386.
Package has a Suggests on npm which cannot be satisfied on amd64.
Package has a Suggests on npm which cannot be satisfied on i386.
Package has a Suggests on npm which cannot be satisfied on armhf.
Package has a Suggests on npm which cannot be satisfied on mips64el.
Package has a Suggests on npm which cannot be satisfied on arm64.
Package has a Suggests on npm which cannot be satisfied on ppc64el.
Package has a Suggests on npm which cannot be satisfied on s390x.
Package has a Suggests on npm which cannot be satisfied on armel.

Binary Package: libnode115 (Version: 20.10.0+dfsg-1)

BTS entry: https://bugs.debian.org/libnode115

Relationships

Package has a Depends on sse2-support which cannot be satisfied on i386.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on armhf.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on mips64el.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on i386.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on amd64.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on armel.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on s390x.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on ppc64el.
Package has a Depends on libnghttp2-14 (>= 1.41.0) which cannot be satisfied on arm64.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on s390x.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on armel.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on arm64.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on ppc64el.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on mips64el.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on armhf.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on amd64.
Package has a Depends on node-acorn (>= 6.2.1~) which cannot be satisfied on i386.
Package has a Depends on libgcc-s1 (>= 3.5) which cannot be satisfied on armel.
Package has a Depends on libgcc-s1 (>= 3.5) which cannot be satisfied on armhf.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on mips64el.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on armhf.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on i386.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on amd64.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on armel.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on s390x.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on ppc64el.
Package has a Depends on libuv1 (>= 1.46.0) which cannot be satisfied on arm64.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on ppc64el.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on arm64.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on armel.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on s390x.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on i386.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on amd64.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on armhf.
Package has a Depends on node-undici (>= 5.0.0~) which cannot be satisfied on mips64el.
Package has a Depends on vfpv2-support which cannot be satisfied on armel.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on i386.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on amd64.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on armhf.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on mips64el.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on ppc64el.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on arm64.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on armel.
Package has a Depends on libbrotli1 (>= 1.0.0) which cannot be satisfied on s390x.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on armel.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on s390x.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on ppc64el.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on arm64.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on mips64el.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on armhf.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on amd64.
Package has a Depends on libstdc++6 (>= 13.1) which cannot be satisfied on i386.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on mips64el.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on armhf.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on amd64.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on i386.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on s390x.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on armel.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on arm64.
Package has a Depends on node-cjs-module-lexer (>= 1.2.2~) which cannot be satisfied on ppc64el.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on amd64.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on i386.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on armhf.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on mips64el.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on arm64.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on ppc64el.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on s390x.
Package has a Depends on libicu72 (>= 72.1~rc-1~) which cannot be satisfied on armel.
Package has a Depends on armv6k-support which cannot be satisfied on armel.
Package has a Depends on libgcc-s1 (>= 3.4) which cannot be satisfied on mips64el.
Package has a Depends on libgcc-s1 (>= 3.4) which cannot be satisfied on amd64.
Package has a Depends on libgcc-s1 (>= 7) which cannot be satisfied on i386.

Binary Package: libnode-dev (Version: 20.10.0+dfsg-1)

BTS entry: https://bugs.debian.org/libnode-dev

Relationships

Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on mips64el.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on armhf.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on i386.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on amd64.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on armel.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on s390x.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on ppc64el.
Package has a Depends on libuv1-dev (>= 1.33.0~) which cannot be satisfied on arm64.


Last updated: Fri Mar 1 15:25:01 2024

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS