Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid trixie bookworm bullseye

Problems for source package opendht

Current Source Version: 3.0.0-4
Current Maintainer: Amin Bandali <bandali@gnu.org>
Section: main
BTS entry: https://bugs.debian.org/src:opendht

Half Broken Build-Depends

(not necessarily bugs)

Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on amd64. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on i386. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on armhf. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on mips64el. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on ppc64el. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on s390x. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on arm64. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package declares a build time dependency on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on armel. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.

Malformed Build-Depends

Package declares a build time dependency on 'python3-all-dev:any' which is broken Syntax.

Binary Package: libopendht-dev (Version: 3.0.0-4+b1)

BTS entry: https://bugs.debian.org/libopendht-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on ppc64el. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on i386. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on amd64. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on armhf. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on mips64el. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on armel. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on arm64. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.
Package has a Depends on libmsgpack-dev (<= 4.0.0) which cannot be satisfied on s390x. libmsgpack-dev 4.0.0-3 is available. At least one of libmsgpack-cxx-dev | libmsgpack-dev (<= 4.0.0) can be satisfied however.


Last updated: Sun Dec 3 15:25:10 2023

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS