Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster stretch jessie

Problems for source package ruby-sinatra

Current Source Version: 2.0.8.1-2
Current Maintainer: Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:ruby-sinatra

Malformed Build-Depends

Package declares a build time dependency on 'ruby-minitest <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-rdiscount <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'puma <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-redcarpet <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-yajl <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-kramdown <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-http <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-rack (>= 2.0~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-sass <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-redcloth <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'rake <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-maruku <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-mustermann <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'thin <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-haml <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-rabl <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-nokogiri <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-tilt (>= 2.0~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-slim (>= 3.0~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-erubis <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-rack-test <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-builder <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-liquid <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-wikicloth <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-json <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-creole <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'ruby-coffee-script <!nocheck>' which is broken Syntax.

Binary Package: ruby-rack-protection (Version: 2.0.8.1-2)

BTS entry: https://bugs.debian.org/ruby-rack-protection

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-interpreter which cannot be satisfied on mips64el. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on mipsel. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on armel. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on i386. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on s390x. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on amd64. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on ppc64el. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on arm64. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on armhf. At least one of ruby | ruby-interpreter can be satisfied however.

Binary Package: ruby-sinatra (Version: 2.0.8.1-2)

BTS entry: https://bugs.debian.org/ruby-sinatra

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-interpreter which cannot be satisfied on arm64. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on armhf. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on amd64. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on ppc64el. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on mipsel. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on armel. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on i386. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on s390x. At least one of ruby | ruby-interpreter can be satisfied however.
Package has a Depends on ruby-interpreter which cannot be satisfied on mips64el. At least one of ruby | ruby-interpreter can be satisfied however.


Last updated: Thu Aug 13 15:25:05 2020

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS