Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package rust-curl

Current Source Version: 0.4.25-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-curl

Malformed Build-Depends

Package declares a build time dependency on 'librust-socket2-0.3+default-dev (>= 0.3.7-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+wincrypt-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+libloaderapi-dev ' which is broken Syntax.
Package declares a build time dependency on 'rustc:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-schannel-0.1+default-dev (>= 0.1.13-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-libc-0.2+default-dev (>= 0.2.42-~~) ' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev ' which is broken Syntax.
Package declares a build time dependency on 'cargo:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-curl-sys-0.4-dev (>= 0.4.21-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) ' which is broken Syntax.

Binary Package: librust-curl+ssl-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+ssl-dev

Relationships

Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on i386.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on armel.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on i386.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on armel.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on armel.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on i386.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-curl-sys-0.4+ssl-dev (>= 0.4.21-~~) which cannot be satisfied on arm64.

Binary Package: librust-curl+force-system-lib-on-osx-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+force-system-lib-on-osx-dev

Relationships

Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on armel.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on i386.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-curl-sys-0.4+force-system-lib-on-osx-dev (>= 0.4.21-~~) which cannot be satisfied on mipsel.

Binary Package: librust-curl-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl-dev

Relationships

Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+wincrypt-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on armel.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on i386.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-curl-sys-0.4-dev (>= 0.4.21-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on armel.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on i386.
Package has a Depends on librust-libc-0.2+default-dev (>= 0.2.42-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+libloaderapi-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on i386.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on armel.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-socket2-0.3+default-dev (>= 0.3.7-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on armel.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on i386.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-schannel-0.1+default-dev (>= 0.1.13-~~) which cannot be satisfied on arm64.

Binary Package: librust-curl+openssl-probe-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+openssl-probe-dev

Relationships

Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on i386.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on armel.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-probe-0.1+default-dev (>= 0.1.2-~~) which cannot be satisfied on arm64.

Binary Package: librust-curl+static-curl-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+static-curl-dev

Relationships

Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on i386.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on armel.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-curl-sys-0.4+static-curl-dev (>= 0.4.21-~~) which cannot be satisfied on mips64el.

Binary Package: librust-curl+openssl-sys-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+openssl-sys-dev

Relationships

Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on armel.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on i386.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-sys-0.9+default-dev (>= 0.9.43-~~) which cannot be satisfied on ppc64el.

Binary Package: librust-curl+http2-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+http2-dev

Relationships

Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on armel.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on i386.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-curl-sys-0.4+http2-dev (>= 0.4.21-~~) which cannot be satisfied on mips64el.

Binary Package: librust-curl+static-ssl-dev (Version: 0.4.25-1)

BTS entry: https://bugs.debian.org/librust-curl+static-ssl-dev

Relationships

Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on s390x.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on armel.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on i386.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-curl-sys-0.4+static-ssl-dev (>= 0.4.21-~~) which cannot be satisfied on arm64.


Last updated: Sun Dec 15 15:25:07 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS