Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package rust-failure

Current Source Version: 0.1.6-2
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-failure

Malformed Build-Depends

Package declares a build time dependency on 'cargo:native <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-failure-derive-0.1+default-dev (>= 0.1.6-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-backtrace-0.3+default-dev (>= 0.3.3-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'rustc:native <!nocheck>' which is broken Syntax.

Binary Package: librust-failure+failure-derive-dev (Version: 0.1.5-1+b1)

BTS entry: https://bugs.debian.org/librust-failure+failure-derive-dev

Relationships

Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on mips64el. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on amd64. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on armhf. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on i386. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on arm64. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on mipsel. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on s390x. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on ppc64el. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on armel. librust-failure-dev 0.1.6-2 is available.

Binary Package: librust-failure+std-dev (Version: 0.1.5-1+b1)

BTS entry: https://bugs.debian.org/librust-failure+std-dev

Relationships

Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on amd64. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on mips64el. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on mipsel. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on i386. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on armhf. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on arm64. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on s390x. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on armel. librust-failure-dev 0.1.6-2 is available.
Package has a Depends on librust-failure-dev (= 0.1.5-1+b1) which cannot be satisfied on ppc64el. librust-failure-dev 0.1.6-2 is available.


Last updated: Tue Feb 25 15:25:06 2020

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS