Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid

Problems for source package rust-image

Current Source Version: 0.22.1-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-image

Malformed Build-Depends

Package declares a build time dependency on 'librust-lzw-0.10+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'rustc:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-png-0.15+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-jpeg-decoder-0.1+rayon-dev ' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-byteorder-1+default-dev (>= 1.2.1-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-num-iter-0.1+default-dev (>= 0.1.32-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-tiff-0.3+default-dev (>= 0.3.1-~~) ' which is broken Syntax.
Package declares a build time dependency on 'cargo:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-scoped-threadpool-0.1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-jpeg-decoder-0.1-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-num-rational-0.2-dev (>= 0.2.1-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-num-traits-0.2+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-gif-0.10+default-dev ' which is broken Syntax.

Binary Package: librust-image+jpeg-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+jpeg-dev

Relationships

Package has a Depends on librust-jpeg-decoder-0.1-dev which cannot be satisfied on amd64.

Binary Package: librust-image+hdr-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+hdr-dev

Relationships

Package has a Depends on librust-scoped-threadpool-0.1+default-dev which cannot be satisfied on amd64.

Binary Package: librust-image+jpeg-rayon-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+jpeg-rayon-dev

Relationships

Package has a Depends on librust-jpeg-decoder-0.1+rayon-dev which cannot be satisfied on amd64.

Binary Package: librust-image+default-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+default-dev

Relationships

Package has a Depends on librust-image+dxt-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-image+tga-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-image+png-codec-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-tiff-0.3+default-dev (>= 0.3.1-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-image+pnm-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-image+webp-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-image+gif-codec-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-image+bmp-dev (= 0.22.1-1) which cannot be satisfied on amd64.

Binary Package: librust-image+tiff-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+tiff-dev

Relationships

Package has a Depends on librust-tiff-0.3+default-dev (>= 0.3.1-~~) which cannot be satisfied on amd64.

Binary Package: librust-image+png-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+png-dev

Relationships

Package has a Depends on librust-png-0.15+default-dev which cannot be satisfied on amd64.

Binary Package: librust-image-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image-dev

Relationships

Package has a Depends on librust-lzw-0.10+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-num-iter-0.1+default-dev (>= 0.1.32-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-byteorder-1+default-dev (>= 1.2.1-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-num-rational-0.2-dev (>= 0.2.1-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-num-traits-0.2+default-dev which cannot be satisfied on amd64.

Binary Package: librust-image+ico-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+ico-dev

Relationships

Package has a Depends on librust-image+png-codec-dev (= 0.22.1-1) which cannot be satisfied on amd64.
Package has a Depends on librust-image+bmp-dev (= 0.22.1-1) which cannot be satisfied on amd64.

Binary Package: librust-image+gif-dev (Version: 0.22.1-1)

BTS entry: https://bugs.debian.org/librust-image+gif-dev

Relationships

Package has a Depends on librust-gif-0.10+default-dev which cannot be satisfied on amd64.


Last updated: Thu Dec 12 15:25:07 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS