Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid

Problems for source package rust-ring

Current Source Version: 0.16.9-2
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-ring

Malformed Build-Depends

Package declares a build time dependency on 'librust-libc-0.2-dev (>= 0.2.48-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+wtypesbase-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-untrusted-0.7+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-lazy-static-1-dev (>= 1.3-~~) ' which is broken Syntax.
Package declares a build time dependency on 'cargo:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+ntsecapi-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-web-sys-0.3+crypto-dev (>= 0.3.25-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-web-sys-0.3+window-dev (>= 0.3.25-~~) ' which is broken Syntax.
Package declares a build time dependency on 'rustc:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-cc-1-dev (>= 1.0.37-~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-spin-0.5-dev (>= 0.5.2-~~) ' which is broken Syntax.

Binary Package: librust-ring-dev (Version: 0.16.9-2)

BTS entry: https://bugs.debian.org/librust-ring-dev

Relationships

Package has a Depends on librust-web-sys-0.3+crypto-dev (>= 0.3.25-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-web-sys-0.3+crypto-dev (>= 0.3.25-~~) which cannot be satisfied on i386.
Package has a Depends on librust-web-sys-0.3+crypto-dev (>= 0.3.25-~~) which cannot be satisfied on armel.
Package has a Depends on librust-web-sys-0.3+crypto-dev (>= 0.3.25-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-web-sys-0.3+crypto-dev (>= 0.3.25-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-web-sys-0.3+window-dev (>= 0.3.25-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-web-sys-0.3+window-dev (>= 0.3.25-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-web-sys-0.3+window-dev (>= 0.3.25-~~) which cannot be satisfied on i386.
Package has a Depends on librust-web-sys-0.3+window-dev (>= 0.3.25-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-web-sys-0.3+window-dev (>= 0.3.25-~~) which cannot be satisfied on armel.
Package has a Depends on librust-spin-0.5-dev (>= 0.5.2-~~) which cannot be satisfied on i386.
Package has a Depends on librust-spin-0.5-dev (>= 0.5.2-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-spin-0.5-dev (>= 0.5.2-~~) which cannot be satisfied on armel.
Package has a Depends on librust-spin-0.5-dev (>= 0.5.2-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-spin-0.5-dev (>= 0.5.2-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+wtypesbase-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+wtypesbase-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+wtypesbase-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+wtypesbase-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+wtypesbase-dev which cannot be satisfied on armhf.
Package has a Depends on librust-cc-1-dev (>= 1.0.37-~~) which cannot be satisfied on armel.
Package has a Depends on librust-cc-1-dev (>= 1.0.37-~~) which cannot be satisfied on i386.
Package has a Depends on librust-cc-1-dev (>= 1.0.37-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-cc-1-dev (>= 1.0.37-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-cc-1-dev (>= 1.0.37-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libc-0.2-dev (>= 0.2.48-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libc-0.2-dev (>= 0.2.48-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libc-0.2-dev (>= 0.2.48-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libc-0.2-dev (>= 0.2.48-~~) which cannot be satisfied on i386.
Package has a Depends on librust-libc-0.2-dev (>= 0.2.48-~~) which cannot be satisfied on armel.
Package has a Depends on librust-untrusted-0.7+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-untrusted-0.7+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-untrusted-0.7+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-untrusted-0.7+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-untrusted-0.7+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+ntsecapi-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+ntsecapi-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+ntsecapi-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+ntsecapi-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+ntsecapi-dev which cannot be satisfied on i386.

Binary Package: librust-ring+dev-urandom-fallback-dev (Version: 0.16.9-2)

BTS entry: https://bugs.debian.org/librust-ring+dev-urandom-fallback-dev

Relationships

Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on armel.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on i386.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on arm64.

Binary Package: librust-ring+default-dev (Version: 0.16.9-2)

BTS entry: https://bugs.debian.org/librust-ring+default-dev

Relationships

Package has a Depends on librust-ring+alloc-dev (= 0.16.9-2) which cannot be satisfied on armel.
Package has a Depends on librust-ring+alloc-dev (= 0.16.9-2) which cannot be satisfied on amd64.
Package has a Depends on librust-ring+alloc-dev (= 0.16.9-2) which cannot be satisfied on i386.
Package has a Depends on librust-ring+alloc-dev (= 0.16.9-2) which cannot be satisfied on armhf.
Package has a Depends on librust-ring+alloc-dev (= 0.16.9-2) which cannot be satisfied on arm64.

Binary Package: librust-ring+lazy-static-dev (Version: 0.16.9-2)

BTS entry: https://bugs.debian.org/librust-ring+lazy-static-dev

Relationships

Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on armhf.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on arm64.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on armel.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on amd64.
Package has a Depends on librust-lazy-static-1-dev (>= 1.3-~~) which cannot be satisfied on i386.


Last updated: Fri Dec 13 15:25:12 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS