Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package rust-rustyline

Current Source Version: 5.0.2-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-rustyline

Malformed Build-Depends

Package declares a build time dependency on 'librust-winapi-0.3+processenv-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+minwindef-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-memchr-2+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'rustc:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+winuser-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+consoleapi-dev ' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-libc-0.2+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-utf8parse-0.1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+handleapi-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-unicode-width-0.1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-nix-0.15+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+wincon-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-log-0.4+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'cargo:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-dirs-2+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+winbase-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-unicode-segmentation-1+default-dev ' which is broken Syntax.

Binary Package: librust-rustyline-dev (Version: 5.0.2-1)

BTS entry: https://bugs.debian.org/librust-rustyline-dev

Relationships

Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on i386.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on s390x.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on i386.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on armhf.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on arm64.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on armel.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on s390x.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on amd64.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on i386.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-nix-0.15+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on armel.

Binary Package: librust-rustyline-dev (Version: 5.0.0-3)

BTS entry: https://bugs.debian.org/librust-rustyline-dev

Relationships

Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-memchr-2+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+consoleapi-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-unicode-width-0.1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-utf8parse-0.1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+minwindef-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+processenv-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+winbase-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-nix-0.14+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-nix-0.14+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-winapi-0.3+handleapi-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+winuser-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-unicode-segmentation-1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-winapi-0.3+wincon-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on mips64el.

Binary Package: librust-rustyline+dirs-dev (Version: 5.0.2-1)

BTS entry: https://bugs.debian.org/librust-rustyline+dirs-dev

Relationships

Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on amd64.

Binary Package: librust-rustyline+dirs-dev (Version: 5.0.0-3)

BTS entry: https://bugs.debian.org/librust-rustyline+dirs-dev

Relationships

Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-dirs-2+default-dev which cannot be satisfied on mips64el.


Last updated: Thu Sep 19 15:25:10 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS