Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid stretch jessie

Problems for source package thin

Current Source Version: 1.7.2-1
Current Maintainer: Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:thin

BuildDepends

Package declares a build time dependency on ruby-eventmachine (>= 1.0.4) which cannot be satisfied on kfreebsd-i386.
Package declares a build time dependency on ruby-eventmachine (>= 1.0.4) which cannot be satisfied on kfreebsd-amd64.
Package declares a build time dependency on ruby-eventmachine (>= 1.0.4) which cannot be satisfied on hurd-i386.

Binary Package: thin (Version: 1.3.1-5+b5)

BTS entry: https://bugs.debian.org/thin

Relationships

Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-amd64.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-amd64.
Package has a Depends on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on kfreebsd-amd64.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-rack1.4 which cannot be satisfied on kfreebsd-amd64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.

Binary Package: thin (Version: 1.6.3-2)

BTS entry: https://bugs.debian.org/thin

Relationships

Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on hurd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on hurd-i386.
Package has a Depends on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on hurd-i386.
Package has a Depends on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on kfreebsd-i386.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-rack1.4 which cannot be satisfied on hurd-i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on kfreebsd-i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.


Last updated: Sun May 19 15:25:20 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS