Debcheck

 

Back to QA

Debcheck - bookworm
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: bookworm

Problems for source package rocm-hipamd

Current Source Version: 5.2.3-8
Current Maintainer: Debian ROCm Team <debian-ai@lists.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:rocm-hipamd

BuildDepends

Package declares a build time dependency on libhsa-runtime-dev (>= 5.2.0~) which cannot be satisfied on armhf. Package rocm-hipamd does not exist on armhf.
Package declares a build time dependency on libhsa-runtime-dev (>= 5.2.0~) which cannot be satisfied on mipsel. Package rocm-hipamd does not exist on mipsel.
Package declares a build time dependency on libhsa-runtime-dev (>= 5.2.0~) which cannot be satisfied on i386. Package rocm-hipamd does not exist on i386.
Package declares a build time dependency on libhsa-runtime-dev (>= 5.2.0~) which cannot be satisfied on armel. Package rocm-hipamd does not exist on armel.
Package declares a build time dependency on libamd-comgr-dev (>= 5.2.0~) which cannot be satisfied on armel. Package rocm-hipamd does not exist on armel.
Package declares a build time dependency on libamd-comgr-dev (>= 5.2.0~) which cannot be satisfied on i386. Package rocm-hipamd does not exist on i386.
Package declares a build time dependency on libamd-comgr-dev (>= 5.2.0~) which cannot be satisfied on armhf. Package rocm-hipamd does not exist on armhf.
Package declares a build time dependency on libamd-comgr-dev (>= 5.2.0~) which cannot be satisfied on mipsel. Package rocm-hipamd does not exist on mipsel.

Binary Package: hipcc (Version: 5.2.3-8)

BTS entry: https://bugs.debian.org/hipcc

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on libclang-rt-15-dev (>= 1:15.0.6-5~exp1) which cannot be satisfied on s390x. At least one of libclang-common-15-dev (<< 1:15.0.6-5~exp1) | libclang-rt-15-dev (>= 1:15.0.6-5~exp1) can be satisfied however.
Package has a Depends on libclang-rt-15-dev (>= 1:15.0.6-5~exp1) which cannot be satisfied on amd64. At least one of libclang-common-15-dev (<< 1:15.0.6-5~exp1) | libclang-rt-15-dev (>= 1:15.0.6-5~exp1) can be satisfied however.
Package has a Depends on libclang-rt-15-dev (>= 1:15.0.6-5~exp1) which cannot be satisfied on ppc64el. At least one of libclang-common-15-dev (<< 1:15.0.6-5~exp1) | libclang-rt-15-dev (>= 1:15.0.6-5~exp1) can be satisfied however.
Package has a Depends on libclang-rt-15-dev (>= 1:15.0.6-5~exp1) which cannot be satisfied on arm64. At least one of libclang-common-15-dev (<< 1:15.0.6-5~exp1) | libclang-rt-15-dev (>= 1:15.0.6-5~exp1) can be satisfied however.


Last updated: Mon May 27 15:27:29 2024

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS