Debcheck

 

Back to QA

Debcheck - buster
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package rust-git2

Current Source Version: 0.7.5-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-git2

Malformed Build-Depends

Package declares a build time dependency on 'librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) ' which is broken Syntax.
Package declares a build time dependency on 'rustc:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-bitflags-1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-url-1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-openssl-probe-0.1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'cargo:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-openssl-sys-0.9+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) ' which is broken Syntax.
Package declares a build time dependency on 'librust-log-0.4+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-libc-0.2+default-dev ' which is broken Syntax.

Binary Package: librust-git2+ssh-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2+ssh-dev

Relationships

Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on armel.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on mips.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on i386.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libgit2-sys-0.7+ssh-dev (>= 0.7.7~~) which cannot be satisfied on s390x.

Binary Package: librust-git2+openssl-sys-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2+openssl-sys-dev

Relationships

Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on i386.

Binary Package: librust-git2-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2-dev

Relationships

Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-bitflags-1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-log-0.4+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-url-1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-libc-0.2+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on armel.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on mips.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on i386.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on s390x.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libgit2-sys-0.7+default-dev (>= 0.7.7~~) which cannot be satisfied on mipsel.

Binary Package: librust-git2+ssh-key-from-memory-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2+ssh-key-from-memory-dev

Relationships

Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on mips.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on armel.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on s390x.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-libgit2-sys-0.7+ssh-key-from-memory-dev (>= 0.7.7~~) which cannot be satisfied on i386.

Binary Package: librust-git2+curl-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2+curl-dev

Relationships

Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on armel.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on mips.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on i386.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libgit2-sys-0.7+curl-dev (>= 0.7.7~~) which cannot be satisfied on s390x.

Binary Package: librust-git2+https-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2+https-dev

Relationships

Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on mips.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on armhf.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on armel.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on mipsel.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on arm64.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on amd64.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on s390x.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on ppc64el.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on i386.
Package has a Depends on librust-libgit2-sys-0.7+https-dev (>= 0.7.7~~) which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-sys-0.9+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on armhf.

Binary Package: librust-git2+openssl-probe-dev (Version: 0.7.5-1)

BTS entry: https://bugs.debian.org/librust-git2+openssl-probe-dev

Relationships

Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on mips.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-openssl-probe-0.1+default-dev which cannot be satisfied on arm64.


Last updated: Thu Oct 17 15:29:00 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS