Debcheck

 

Back to QA

Debcheck - bullseye
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package hostname

Current Source Version: 3.23
Current Maintainer: Michael Meskes <meskes@debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:hostname

BuildDepends

Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on ppc64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mips64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on amd64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on s390x.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on i386.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armhf.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mipsel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on arm64.

Binary Package: hostname (Version: 3.23)

BTS entry: https://bugs.debian.org/hostname

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on s390x.
Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on i386.
Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on mips64el.
Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on amd64.
Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on armhf.
Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on armel.
Package is required and has a Pre-Depends on libc6 (>= 2.4) which is optional on mipsel.
Package is required and has a Pre-Depends on libc6 (>= 2.17) which is optional on arm64.
Package is required and has a Pre-Depends on libc6 (>= 2.17) which is optional on ppc64el.


Last updated: Tue Dec 10 15:26:55 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS