Debcheck

 

Back to QA

Debcheck - bullseye
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster stretch

Problems for source package nvidia-cuda-toolkit

Current Source Version: 10.1.168-3
Current Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Section: non-free
BTS entry: https://bugs.debian.org/src:nvidia-cuda-toolkit

BuildDepends

Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on ppc64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on amd64.

Binary Package: nvidia-cuda-toolkit (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-cuda-toolkit

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on g++-5 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-5 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:8~) which cannot be satisfied on ppc64el. clang 1:8.0-48.3 is available. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:8~) which cannot be satisfied on amd64. clang 1:8.0-48.3 is available. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.9 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.9 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.8 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-4.8 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-6 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on g++-6 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on amd64. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on ppc64el. At least one of g++-8 | clang-8 | clang-7 | g++-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | g++-6 | g++-5 | g++-4.9 | g++-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:8~) which cannot be satisfied on ppc64el. clang 1:8.0-48.3 is available. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang (<< 1:8~) which cannot be satisfied on amd64. clang 1:8.0-48.3 is available. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-6 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-6 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.8 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.8 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.9 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-4.9 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-4.0 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.9 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-3.8 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on clang-5.0 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-5 which cannot be satisfied on ppc64el. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.
Package has a Depends on gcc-5 which cannot be satisfied on amd64. At least one of gcc-8 | clang-8 | clang-7 | gcc-7 | clang-6.0 | clang-5.0 | clang-4.0 | clang-3.9 | clang-3.8 | clang (<< 1:8~) | gcc-6 | gcc-5 | gcc-4.9 | gcc-4.8 can be satisfied however.

Binary Package: nvidia-opencl-dev (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-opencl-dev

Relationships

Package has a Recommends on nvidia-opencl-icd which cannot be satisfied on ppc64el.

Binary Package: nvidia-cuda-gdb (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-cuda-gdb

Old Libraries

Package has a Depends on libncurses5 (>= 6) which is in Section oldlibs on amd64.
Package has a Depends on libncurses5 (>= 6) which is in Section oldlibs on ppc64el.

Binary Package: nvidia-cuda-dev (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-cuda-dev

Relationships

Package has a Recommends on libnvcuvid1 which cannot be satisfied on ppc64el.

Binary Package: libcupti-doc (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/libcupti-doc

Relationships

Package has a Depends on libjs-html5shiv which cannot be satisfied on ppc64el.
Package has a Depends on libjs-html5shiv which cannot be satisfied on amd64.
Package has a Depends on libjs-html5shiv which cannot be satisfied on s390x.
Package has a Depends on libjs-html5shiv which cannot be satisfied on i386.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mipsel.
Package has a Depends on libjs-html5shiv which cannot be satisfied on armel.
Package has a Depends on libjs-html5shiv which cannot be satisfied on armhf.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mips64el.
Package has a Depends on libjs-html5shiv which cannot be satisfied on arm64.

Binary Package: nvidia-visual-profiler (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-visual-profiler

Old Libraries

Package has a Depends on libgtk2.0-0 which is in Section oldlibs on amd64.

Binary Package: nvidia-cuda-doc (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-cuda-doc

Relationships

Package has a Depends on libjs-html5shiv which cannot be satisfied on armel.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mipsel.
Package has a Depends on libjs-html5shiv which cannot be satisfied on armhf.
Package has a Depends on libjs-html5shiv which cannot be satisfied on amd64.
Package has a Depends on libjs-html5shiv which cannot be satisfied on i386.
Package has a Depends on libjs-html5shiv which cannot be satisfied on s390x.
Package has a Depends on libjs-html5shiv which cannot be satisfied on ppc64el.
Package has a Depends on libjs-html5shiv which cannot be satisfied on arm64.
Package has a Depends on libjs-html5shiv which cannot be satisfied on mips64el.

Binary Package: nvidia-nsight (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-nsight

Old Libraries

Package has a Depends on libgtk2.0-0 which is in Section oldlibs on amd64.

Binary Package: nsight-systems (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nsight-systems

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Depends on libgl1 which is extra on amd64.

Binary Package: nsight-compute (Version: 10.1.168-3)

BTS entry: https://bugs.debian.org/nsight-compute

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Depends on libegl1 which is extra on amd64.
Package is optional and has a Depends on libgl1 which is extra on amd64.

Relationships

Package has a Depends on libjs-html5shiv which cannot be satisfied on amd64.

Binary Package: nvidia-openjdk-8-jre (Version: 9.+8u77~10.1.168-3)

BTS entry: https://bugs.debian.org/nvidia-openjdk-8-jre

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Depends on libgl1 which is extra on amd64.

Old Libraries

Package has a Depends on libgtk2.0-0 (>= 2.24.0) which is in Section oldlibs on amd64.


Last updated: Sat Dec 7 15:26:38 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS