Debcheck

 

Back to QA

Debcheck - bullseye
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster stretch jessie

Problems for source package shadow

Current Source Version: 1:4.7-2
Current Maintainer: Shadow package maintainers <pkg-shadow-devel@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:shadow

BuildDepends

Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on arm64. Package shadow does not exist on arm64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armel. Package shadow does not exist on armel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mipsel. Package shadow does not exist on mipsel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on amd64. Package shadow does not exist on amd64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mips64el. Package shadow does not exist on mips64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on i386. Package shadow does not exist on i386.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on ppc64el. Package shadow does not exist on ppc64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on s390x. Package shadow does not exist on s390x.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armhf. Package shadow does not exist on armhf.

Binary Package: passwd (Version: 1:4.7-2)

BTS entry: https://bugs.debian.org/passwd

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is required and has a Depends on libc6 (>= 2.8) which is optional on s390x.
Package is required and has a Depends on libc6 (>= 2.8) which is optional on mips64el.
Package is required and has a Depends on libc6 (>= 2.14) which is optional on amd64.
Package is required and has a Depends on libc6 (>= 2.28) which is optional on mipsel.
Package is required and has a Depends on libc6 (>= 2.28) which is optional on armel.
Package is required and has a Depends on libc6 (>= 2.28) which is optional on i386.
Package is required and has a Depends on libc6 (>= 2.28) which is optional on armhf.
Package is required and has a Depends on libc6 (>= 2.17) which is optional on ppc64el.
Package is required and has a Depends on libc6 (>= 2.17) which is optional on arm64.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on arm64.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on s390x.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on armhf.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on mips64el.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on amd64.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on armel.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on i386.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on mipsel.
Package is required and has a Depends on libselinux1 (>= 1.32) which is optional on ppc64el.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on s390x.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on armhf.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on amd64.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on armel.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on mips64el.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on mipsel.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on i386.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on ppc64el.
Package is required and has a Depends on libpam0g (>= 0.99.7.1) which is optional on arm64.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on arm64.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on ppc64el.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on armel.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on i386.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on amd64.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on mips64el.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on mipsel.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on armhf.
Package is required and has a Depends on libsemanage1 (>= 2.0.3) which is optional on s390x.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on arm64.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on armhf.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on s390x.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on ppc64el.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on amd64.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on mipsel.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on i386.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on mips64el.
Package is required and has a Depends on libaudit1 (>= 1:2.2.1) which is optional on armel.

Binary Package: login (Version: 1:4.7-2)

BTS entry: https://bugs.debian.org/login

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on arm64.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on ppc64el.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on armel.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on amd64.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on mips64el.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on mipsel.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on i386.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on armhf.
Package is required and has a Pre-Depends on libaudit1 (>= 1:2.2.1) which is optional on s390x.
Package is required and has a Pre-Depends on libc6 (>= 2.17) which is optional on arm64.
Package is required and has a Pre-Depends on libc6 (>= 2.17) which is optional on ppc64el.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on arm64.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on ppc64el.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on armel.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on mipsel.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on i386.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on mips64el.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on amd64.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on armhf.
Package is required and has a Pre-Depends on libpam0g (>= 0.99.7.1) which is optional on s390x.
Package is required and has a Pre-Depends on libc6 (>= 2.14) which is optional on amd64.
Package is required and has a Pre-Depends on libc6 (>= 2.7) which is optional on mipsel.
Package is required and has a Pre-Depends on libc6 (>= 2.7) which is optional on armel.
Package is required and has a Pre-Depends on libc6 (>= 2.7) which is optional on mips64el.
Package is required and has a Pre-Depends on libc6 (>= 2.7) which is optional on i386.
Package is required and has a Pre-Depends on libc6 (>= 2.7) which is optional on armhf.
Package is required and has a Pre-Depends on libc6 (>= 2.7) which is optional on s390x.


Last updated: Fri Sep 20 15:27:19 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS