Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid buster stretch jessie wheezy

Problems for source package curl

Current Source Version: 7.55.0-1
Current Maintainer: Alessandro Ghedini <ghedo@debian.org>
Section: main
BTS entry: http://bugs.debian.org/src:curl

Binary Package: libcurl4-openssl-dev (Version: 7.55.0-1)

BTS entry: http://bugs.debian.org/libcurl4-openssl-dev

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority optional (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on s390x.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on mips64el.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on arm64.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on mipsel.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on i386.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on hurd-i386.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on amd64.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on mips.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on ppc64el.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on armhf.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on armel.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on armhf.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on armel.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on ppc64el.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on mips.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on amd64.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on hurd-i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on mipsel.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on mips64el.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on s390x.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on arm64.

Half Broken Relationships

(not necessarily bugs)

Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on hurd-i386. libssl-dev 1.1.0e-2 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on i386. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on mipsel. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on s390x. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on mips64el. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on arm64. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on armhf. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on armel. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on ppc64el. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on mips. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on amd64. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.

Binary Package: libcurl4-openssl-dev (Version: 7.52.1-5)

BTS entry: http://bugs.debian.org/libcurl4-openssl-dev

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority optional (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on kfreebsd-i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on kfreebsd-amd64.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on powerpc.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on kfreebsd-i386.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on kfreebsd-amd64.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on powerpc.

Half Broken Relationships

(not necessarily bugs)

Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on kfreebsd-i386. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on powerpc. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.
Package has a Suggests on libssl-dev (<< 1.1) which cannot be satisfied on kfreebsd-amd64. libssl-dev 1.1.0f-4 is available. At least one of libssl1.0-dev | libssl-dev (<< 1.1) can be satisfied however.

Binary Package: libcurl3-nss (Version: 7.55.0-1)

BTS entry: http://bugs.debian.org/libcurl3-nss

Old Libraries

Package has a Depends on libnspr4-0d (>= 1.8.0.10) which is in Section oldlibs on hurd-i386.

Binary Package: libcurl4-nss-dev (Version: 7.52.1-5)

BTS entry: http://bugs.debian.org/libcurl4-nss-dev

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority optional (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on kfreebsd-i386.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on powerpc.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on kfreebsd-amd64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on powerpc.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on kfreebsd-amd64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on kfreebsd-i386.

Binary Package: libcurl4-nss-dev (Version: 7.55.0-1)

BTS entry: http://bugs.debian.org/libcurl4-nss-dev

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority optional (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on arm64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on s390x.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on mips64el.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on mipsel.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on i386.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on hurd-i386.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on amd64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on mips.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on ppc64el.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on armhf.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on armel.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on hurd-i386.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on i386.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on mipsel.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on s390x.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on arm64.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on mips64el.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on armhf.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on armel.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on ppc64el.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on mips.
Package is optional and has a Conflicts on libcurl4-gnutls-dev which is optional on amd64.

Binary Package: libcurl4-gnutls-dev (Version: 7.55.0-1)

BTS entry: http://bugs.debian.org/libcurl4-gnutls-dev

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority optional (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on amd64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on mips.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on ppc64el.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on armhf.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on armel.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on s390x.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on arm64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on mips64el.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on mipsel.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on i386.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on hurd-i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on hurd-i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on mipsel.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on arm64.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on s390x.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on mips64el.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on armel.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on armhf.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on ppc64el.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on mips.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on amd64.

Binary Package: libcurl4-gnutls-dev (Version: 7.52.1-5)

BTS entry: http://bugs.debian.org/libcurl4-gnutls-dev

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority optional (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on kfreebsd-i386.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on powerpc.
Package is optional and has a Conflicts on libcurl4-nss-dev which is optional on kfreebsd-amd64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on powerpc.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on kfreebsd-amd64.
Package is optional and has a Conflicts on libcurl4-openssl-dev which is optional on kfreebsd-i386.


Last updated: Thu Aug 17 15:25:16 2017

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS