Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid buster stretch jessie wheezy

Problems for source package eclipse

Current Source Version: 3.8.1-10
Current Maintainer: Debian Orbital Alignment Team <pkg-java-maintainers@lists.alioth.debian.org>
Section: main
BTS entry: http://bugs.debian.org/src:eclipse

Binary Package: eclipse-jdt (Version: 3.8.1-10)

BTS entry: http://bugs.debian.org/eclipse-jdt

Relationships

Package has a Depends on eclipse-platform (>= 3.8.1-10) which cannot be satisfied on mips64el.
Package has a Depends on eclipse-platform (>= 3.8.1-10) which cannot be satisfied on hurd-i386.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on java6-runtime which cannot be satisfied on hurd-i386. At least one of default-jre | java5-runtime | java6-runtime can be satisfied however.

Binary Package: eclipse-jdt (Version: 3.8.1-8)

BTS entry: http://bugs.debian.org/eclipse-jdt

Half Broken Relationships

(not necessarily bugs)

Package has a Recommends on sun-java6-jdk which cannot be satisfied on kfreebsd-amd64. At least one of default-jdk | sun-java6-jdk can be satisfied however.
Package has a Recommends on sun-java6-jdk which cannot be satisfied on kfreebsd-i386. At least one of default-jdk | sun-java6-jdk can be satisfied however.

Binary Package: eclipse-platform-data (Version: 3.8.1-8)

BTS entry: http://bugs.debian.org/eclipse-platform-data

Relationships

Package has a Depends on libtomcat7-java which cannot be satisfied on kfreebsd-amd64.
Package has a Depends on libtomcat7-java which cannot be satisfied on kfreebsd-i386.

Binary Package: eclipse (Version: 3.8.1-10)

BTS entry: http://bugs.debian.org/eclipse

Relationships

Package has a Depends on eclipse-pde (>= 3.8.1-10) which cannot be satisfied on hurd-i386.
Package has a Depends on eclipse-pde (>= 3.8.1-10) which cannot be satisfied on mips64el.

Binary Package: eclipse-platform (Version: 3.8.1-8)

BTS entry: http://bugs.debian.org/eclipse-platform

Relationships

Package has a Depends on libjetty8-java which cannot be satisfied on kfreebsd-i386.
Package has a Depends on libjetty8-java which cannot be satisfied on kfreebsd-amd64.


Last updated: Tue Jun 27 15:25:26 2017

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS