Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster jessie

Problems for source package ifupdown

Current Source Version: 0.8.35
Current Maintainer: Guus Sliepen <guus@debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:ifupdown

BuildDepends

Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on arm64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on ppc64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mips64el.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on i386.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on mipsel.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on amd64.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on armhf.
Package declares a build time dependency on debhelper-compat (= 12) which cannot be satisfied on s390x.

Binary Package: ifupdown (Version: 0.8.35)

BTS entry: https://bugs.debian.org/ifupdown

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is important and has a Depends on libc6 (>= 2.8) which is optional on mips64el.
Package is important and has a Depends on libc6 (>= 2.8) which is optional on s390x.
Package is important and has a Depends on libc6 (>= 2.17) which is optional on ppc64el.
Package is important and has a Depends on libc6 (>= 2.17) which is optional on arm64.
Package is important and has a Depends on libc6 (>= 2.28) which is optional on armel.
Package is important and has a Depends on libc6 (>= 2.28) which is optional on armhf.
Package is important and has a Depends on libc6 (>= 2.28) which is optional on mipsel.
Package is important and has a Depends on libc6 (>= 2.28) which is optional on i386.
Package is important and has a Depends on lsb-base which is optional on armel.
Package is important and has a Depends on lsb-base which is optional on ppc64el.
Package is important and has a Depends on lsb-base which is optional on arm64.
Package is important and has a Depends on lsb-base which is optional on i386.
Package is important and has a Depends on lsb-base which is optional on mipsel.
Package is important and has a Depends on lsb-base which is optional on mips64el.
Package is important and has a Depends on lsb-base which is optional on armhf.
Package is important and has a Depends on lsb-base which is optional on s390x.

Binary Package: ifupdown (Version: 0.8.35+b1)

BTS entry: https://bugs.debian.org/ifupdown

Priority

According to Policy Section 2.5: Priorities packages MUST NOT depend on packages with lower priority values (excluding build-time dependencies) nor should packages of priority standard (or higher) conflict with each other. In order to ensure this, the priorities of one or more packages must be adjusted.

Package is important and has a Depends on lsb-base which is optional on amd64.
Package is important and has a Depends on libc6 (>= 2.14) which is optional on amd64.


Last updated: Thu Aug 22 15:25:16 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS