Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid buster stretch jessie

Problems for source package node-compression

Current Source Version: 1.7.3-2
Current Maintainer: Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:node-compression

Malformed Build-Depends

Package declares a build time dependency on 'node-debug (>= 2.6.9) ' which is broken Syntax.
Package declares a build time dependency on 'node-safe-buffer (>= 5.1.1) ' which is broken Syntax.
Package declares a build time dependency on 'node-bytes (>= 3.0.0) ' which is broken Syntax.
Package declares a build time dependency on 'node-accepts (>= 1.1.1) ' which is broken Syntax.
Package declares a build time dependency on 'node-after (>= 0.8.2) ' which is broken Syntax.
Package declares a build time dependency on 'node-compressible (>= 2.0.1) ' which is broken Syntax.
Package declares a build time dependency on 'mocha (>= 4) ' which is broken Syntax.
Package declares a build time dependency on 'nodejs (>= 6) ' which is broken Syntax.
Package declares a build time dependency on 'node-supertest (>= 0.14.0) ' which is broken Syntax.
Package declares a build time dependency on 'node-on-headers (>= 1.0.0) ' which is broken Syntax.
Package declares a build time dependency on 'node-vary (>= 1.0.0) ' which is broken Syntax.

Binary Package: node-compression (Version: 1.7.3-2)

BTS entry: https://bugs.debian.org/node-compression

Relationships

Package has a Depends on nodejs which cannot be satisfied on hurd-i386.
Package has a Depends on nodejs which cannot be satisfied on armel.


Last updated: Sat Dec 15 15:25:21 2018

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS