Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid

Problems for source package node-diffie-hellman

Current Source Version: 5.0.2-3
Current Maintainer: Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:node-diffie-hellman

BuildDepends

Package declares a build time dependency on nodejs (>= 4.7) which cannot be satisfied on armel.
Package declares a build time dependency on nodejs (>= 4.7) which cannot be satisfied on hurd-i386.
Package declares a build time dependency on nodejs (>= 4.7) which cannot be satisfied on kfreebsd-i386. nodejs 4.6.1~dfsg-1 is available.
Package declares a build time dependency on nodejs (>= 4.7) which cannot be satisfied on kfreebsd-amd64. nodejs 4.6.1~dfsg-1 is available.

Malformed Build-Depends

Package declares a build time dependency on 'node-bn.js (>= 4.1.0) ' which is broken Syntax.
Package declares a build time dependency on 'node-randombytes (>= 2.0.0) ' which is broken Syntax.
Package declares a build time dependency on 'node-tape (>= 3.0.1) ' which is broken Syntax.
Package declares a build time dependency on 'node-miller-rabin (>= 4.0.0) ' which is broken Syntax.

Binary Package: node-diffie-hellman (Version: 5.0.2-3)

BTS entry: https://bugs.debian.org/node-diffie-hellman

Relationships

Package has a Depends on nodejs (>= 4.7) which cannot be satisfied on hurd-i386.
Package has a Depends on nodejs (>= 4.7) which cannot be satisfied on armel.
Package has a Depends on nodejs (>= 4.7) which cannot be satisfied on kfreebsd-i386. nodejs 4.6.1~dfsg-1 is available.
Package has a Depends on nodejs (>= 4.7) which cannot be satisfied on kfreebsd-amd64. nodejs 4.6.1~dfsg-1 is available.


Last updated: Tue Dec 11 15:25:12 2018

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS