Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bookworm

Problems for source package ros2-rosidl

Current Source Version: 3.3.0-1
Current Maintainer: Debian Robotics Team <team+robotics@tracker.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:ros2-rosidl

Binary Package: rosidl-generator-c-cpp (Version: 3.3.0-1)

BTS entry: https://bugs.debian.org/rosidl-generator-c-cpp

Relationships

Package has a Depends on librosidl-runtime-c-cpp-dev which cannot be satisfied on armhf.
Package has a Depends on librosidl-runtime-c-cpp-dev which cannot be satisfied on armel.
Package has a Depends on librosidl-typesupport-introspection-c-cpp-dev which cannot be satisfied on armel.
Package has a Depends on librosidl-typesupport-introspection-c-cpp-dev which cannot be satisfied on armhf.

Binary Package: rosidl-generators (Version: 3.2.1-1)

BTS entry: https://bugs.debian.org/rosidl-generators

Relationships

Package has a Depends on librosidl-runtime-dev which cannot be satisfied on armhf.
Package has a Depends on librosidl-runtime-dev which cannot be satisfied on armel.

Binary Package: librosidl-runtime-dev (Version: 3.2.1-1)

BTS entry: https://bugs.debian.org/librosidl-runtime-dev

Relationships

Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on s390x. librosidl-runtime-c0d 3.3.0-1+b1 is available.
Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on ppc64el. librosidl-runtime-c0d 3.3.0-1+b1 is available.
Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on mipsel. librosidl-runtime-c0d 3.3.0-1+b1 is available.
Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on arm64. librosidl-runtime-c0d 3.3.0-1+b1 is available.
Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on amd64. librosidl-runtime-c0d 3.3.0-1+b1 is available.
Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on mips64el. librosidl-runtime-c0d 3.3.0-1+b1 is available.
Package has a Depends on librosidl-runtime-c0d (= 3.2.1-1) which cannot be satisfied on i386. librosidl-runtime-c0d 3.3.0-1+b1 is available.


Last updated: Tue Oct 4 15:25:07 2022

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS