Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bookworm bullseye buster stretch

Problems for source package ruby-sdl

Current Source Version: 2.2.0-1
Current Maintainer: Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:ruby-sdl

Binary Package: ruby-sdl (Version: 2.2.0-1+b6)

BTS entry: https://bugs.debian.org/ruby-sdl

Old Libraries

Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on s390x.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on amd64.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on ppc64el.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on arm64.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on armhf.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on mips64el.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on armel.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on i386.
Package has a Depends on libsdl-sge (>= 030809-1) which is in Section oldlibs on mipsel.

Relationships

Package has a Suggests on ruby-opengl which cannot be satisfied on armhf.
Package has a Suggests on ruby-opengl which cannot be satisfied on ppc64el.
Package has a Suggests on ruby-opengl which cannot be satisfied on arm64.
Package has a Suggests on ruby-opengl which cannot be satisfied on s390x.
Package has a Suggests on ruby-opengl which cannot be satisfied on amd64.
Package has a Suggests on ruby-opengl which cannot be satisfied on mipsel.
Package has a Suggests on ruby-opengl which cannot be satisfied on mips64el.
Package has a Suggests on ruby-opengl which cannot be satisfied on armel.
Package has a Suggests on ruby-opengl which cannot be satisfied on i386.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on s390x. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on amd64. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on armhf. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on ppc64el. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on arm64. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on mips64el. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on i386. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on armel. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.
Package has a Depends on ruby (>= 1:3.0~0) which cannot be satisfied on mipsel. ruby 1:2.7.6 is available. At least one of ruby (>= 1:2.7~0) | ruby (>= 1:3.0~0) can be satisfied however.


Last updated: Mon Jan 17 15:25:06 2022

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS