Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye buster

Problems for source package rust-libflate

Current Source Version: 0.1.25-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-libflate

BuildDepends

Package declares a build time dependency on debhelper (>= 11) which cannot be satisfied on mips. Package rust-libflate does not exist on mips.
Package declares a build time dependency on dh-cargo (>= 15) which cannot be satisfied on mips. Package rust-libflate does not exist on mips.

Malformed Build-Depends

Package declares a build time dependency on 'librust-byteorder-1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-take-mut-0.2+default-dev (>= 0.2.2-~~) ' which is broken Syntax.
Package declares a build time dependency on 'cargo:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-adler32-1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev ' which is broken Syntax.
Package declares a build time dependency on 'rustc:native ' which is broken Syntax.
Package declares a build time dependency on 'librust-crc32fast-1+default-dev ' which is broken Syntax.
Package declares a build time dependency on 'librust-rle-decode-fast-1+default-dev ' which is broken Syntax.

Binary Package: librust-libflate-dev (Version: 0.1.19-1)

BTS entry: https://bugs.debian.org/librust-libflate-dev

Relationships

Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-byteorder-1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on mipsel.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-crc32fast-1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on mips64el.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on armhf.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on i386.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on s390x.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on arm64.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on armel.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on ppc64el.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on amd64.
Package has a Depends on librust-adler32-1+default-dev which cannot be satisfied on mipsel.


Last updated: Wed Aug 21 15:25:11 2019

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS