Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid

Problems for source package rust-listenfd

Current Source Version: 0.3.3-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-listenfd

Malformed Build-Depends

Package declares a build time dependency on 'librust-libc-0.2+default-dev (>= 0.2.40-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'libstd-rust-dev <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+processthreadsapi-dev (>= 0.3.4-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'rustc:native <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+winsock2-dev (>= 0.3.4-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-winapi-0.3+default-dev (>= 0.3.4-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'librust-uuid-0.8+default-dev <!nocheck> | librust-uuid-0.7+default-dev <!nocheck> | librust-uuid-0.6+default-dev (>= 0.6.3-~~) <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'cargo:native <!nocheck>' which is broken Syntax.

Binary Package: librust-listenfd-dev (Version: 0.3.3-1)

BTS entry: https://bugs.debian.org/librust-listenfd-dev

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on armel. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on armhf. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on ppc64el. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on mipsel. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on i386. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on s390x. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on arm64. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on amd64. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.6+default-dev (>= 0.6.3-~~) which cannot be satisfied on mips64el. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on mips64el. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on amd64. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on arm64. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on i386. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on s390x. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on mipsel. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on ppc64el. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on armhf. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.
Package has a Depends on librust-uuid-0.7+default-dev which cannot be satisfied on armel. At least one of librust-uuid-0.8+default-dev | librust-uuid-0.7+default-dev | librust-uuid-0.6+default-dev (>= 0.6.3-~~) can be satisfied however.


Last updated: Wed Feb 26 15:25:06 2020

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS