Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid trixie bookworm bullseye buster

Problems for source package rust-url

Current Source Version: 2.5.0-1
Current Maintainer: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
Section: main
BTS entry: https://bugs.debian.org/src:rust-url

Malformed Build-Depends

Package declares a build time dependency on 'cargo:native <!nocheck>' which is broken Syntax.
Package declares a build time dependency on 'rustc:native (>= 1.56) <!nocheck>' which is broken Syntax.

Binary Package: librust-url+serde-dev (Version: 2.4.0-2)

BTS entry: https://bugs.debian.org/librust-url+serde-dev

Relationships

Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on s390x. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on armel. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on arm64. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on i386. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on armhf. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on amd64. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on mips64el. librust-url-dev 2.5.0-1 is available.
Package has a Depends on librust-url-dev (= 2.4.0-2) which cannot be satisfied on ppc64el. librust-url-dev 2.5.0-1 is available.


Last updated: Sun Mar 3 15:25:13 2024

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS