Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid trixie bookworm

Problems for source package spyder

Current Source Version: 5.5.0+ds-3
Current Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:spyder

BuildDepends

Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on ppc64el. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on mips64el. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on i386. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on amd64. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on arm64. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on s390x. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on armel. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pylsp (<< 1.10~) which cannot be satisfied on armhf. python3-pylsp 1.10.0-1 is available.
Package declares a build time dependency on python3-pyqt5.qtwebengine (<< 5.16~) which cannot be satisfied on armel.
Package declares a build time dependency on python3-pyqt5.qtwebengine (<< 5.16~) which cannot be satisfied on s390x.
Package declares a build time dependency on python3-pyqt5.qtwebengine (<< 5.16~) which cannot be satisfied on ppc64el.

Binary Package: python3-spyder (Version: 5.5.0+ds-3)

BTS entry: https://bugs.debian.org/python3-spyder

Relationships

Package has a Depends on python3-pyqt5.qtwebengine (<< 5.16~) which cannot be satisfied on s390x.
Package has a Depends on python3-pyqt5.qtwebengine (<< 5.16~) which cannot be satisfied on armel.
Package has a Depends on python3-pyqt5.qtwebengine (<< 5.16~) which cannot be satisfied on ppc64el.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on amd64. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on ppc64el. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on i386. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on mips64el. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on armhf. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on armel. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on s390x. python3-pylsp 1.10.0-1 is available.
Package has a Depends on python3-pylsp (<< 1.10~) which cannot be satisfied on arm64. python3-pylsp 1.10.0-1 is available.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on amd64. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on ppc64el. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on mips64el. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on i386. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on armhf. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on armel. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on s390x. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<< 3.8) which cannot be satisfied on arm64. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<< 3.8) | python3-supported-min (>= 3.9) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on mips64el. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on i386. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on ppc64el. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on amd64. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on arm64. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on armhf. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on armel. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.
Package has a Depends on python3-supported-max (<= 3.8) which cannot be satisfied on s390x. At least one of python3-ipython (>= 8.13.0) | python3-supported-max (<= 3.8) can be satisfied however.


Last updated: Tue Feb 20 15:25:14 2024

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS