Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid bullseye

Problems for source package stylish-haskell

Current Source Version: 0.12.2.0-1
Current Maintainer: Sean Whitton <spwhitton@spwhitton.name>
Section: main
BTS entry: https://bugs.debian.org/src:stylish-haskell

BuildDepends

Package declares a build time dependency on libghc-ghc-lib-parser-dev (>= 8.10) which cannot be satisfied on mips64el. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on armel. libghc-aeson-prof 2.1.2.1-5 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on i386. libghc-aeson-prof 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on amd64. libghc-aeson-prof 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on armhf. libghc-aeson-prof 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on arm64. libghc-aeson-prof 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on s390x. libghc-aeson-prof 2.1.2.1-5 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on ppc64el. libghc-aeson-prof 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-prof (<< 1.5) which cannot be satisfied on mips64el. libghc-aeson-prof 2.1.2.1-5 is available. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on ppc64el. libghc-aeson-dev 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on mips64el. libghc-aeson-dev 2.1.2.1-5 is available. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on i386. libghc-aeson-dev 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on armel. libghc-aeson-dev 2.1.2.1-5 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on arm64. libghc-aeson-dev 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on armhf. libghc-aeson-dev 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on amd64. libghc-aeson-dev 2.1.2.1-5 is available.
Package declares a build time dependency on libghc-aeson-dev (<< 1.6) which cannot be satisfied on s390x. libghc-aeson-dev 2.1.2.1-5 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on armel. libghc-semigroups-dev 0.20-2+b1 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on i386. libghc-semigroups-dev 0.20-2 is available.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on armhf. libghc-semigroups-dev 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on amd64. libghc-semigroups-dev 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on arm64. libghc-semigroups-dev 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on s390x. libghc-semigroups-dev 0.20-2+b1 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on ppc64el. libghc-semigroups-dev 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-dev (<< 0.20) which cannot be satisfied on mips64el. libghc-semigroups-dev 0.20-2+b1 is available. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on armel. libghc-strict-dev 0.5-1+b1 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on i386. libghc-strict-dev 0.5-1+b1 is available.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on arm64. libghc-strict-dev 0.5-1+b1 is available.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on armhf. libghc-strict-dev 0.5-1+b1 is available.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on amd64. libghc-strict-dev 0.5-1+b1 is available.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on s390x. libghc-strict-dev 0.5-1+b1 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on ppc64el. libghc-strict-dev 0.5-1+b1 is available.
Package declares a build time dependency on libghc-strict-dev (<< 0.5) which cannot be satisfied on mips64el. libghc-strict-dev 0.5-1+b1 is available. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on ppc64el. libghc-ghc-lib-parser-dev 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on mips64el. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on armel. libghc-ghc-lib-parser-dev 9.4.7.20230826-1 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on i386. libghc-ghc-lib-parser-dev 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on arm64. libghc-ghc-lib-parser-dev 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on armhf. libghc-ghc-lib-parser-dev 9.4.7.20230826-1+b1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on amd64. libghc-ghc-lib-parser-dev 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-dev (<< 8.12) which cannot be satisfied on s390x. libghc-ghc-lib-parser-dev 9.4.7.20230826-1 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on s390x. libghc-ghc-lib-parser-prof 9.4.7.20230826-1 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on i386. libghc-ghc-lib-parser-prof 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on armel. libghc-ghc-lib-parser-prof 9.4.7.20230826-1 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on arm64. libghc-ghc-lib-parser-prof 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on armhf. libghc-ghc-lib-parser-prof 9.4.7.20230826-1+b1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on amd64. libghc-ghc-lib-parser-prof 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on mips64el. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (<< 8.12) which cannot be satisfied on ppc64el. libghc-ghc-lib-parser-prof 9.4.7.20230826-1 is available.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on ppc64el. libghc-semigroups-prof 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on mips64el. libghc-semigroups-prof 0.20-2+b1 is available. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on armhf. libghc-semigroups-prof 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on arm64. libghc-semigroups-prof 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on amd64. libghc-semigroups-prof 0.20-2+b1 is available.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on armel. libghc-semigroups-prof 0.20-2+b1 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on i386. libghc-semigroups-prof 0.20-2 is available.
Package declares a build time dependency on libghc-semigroups-prof (<< 0.20) which cannot be satisfied on s390x. libghc-semigroups-prof 0.20-2+b1 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on s390x. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available. Package stylish-haskell does not exist on s390x.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on armhf. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on arm64. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on amd64. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on i386. libghc-optparse-applicative-dev 0.17.1.0-1 is available.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on armel. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available. Package stylish-haskell does not exist on armel.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on mips64el. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available. Package stylish-haskell does not exist on mips64el.
Package declares a build time dependency on libghc-optparse-applicative-dev (<< 0.16) which cannot be satisfied on ppc64el. libghc-optparse-applicative-dev 0.17.1.0-1+b1 is available.
Package declares a build time dependency on libghc-ghc-lib-parser-prof (>= 8.10) which cannot be satisfied on mips64el. Package stylish-haskell does not exist on mips64el.

Binary Package: stylish-haskell (Version: 0.12.2.0-1+b1)

BTS entry: https://bugs.debian.org/stylish-haskell

Relationships

Package has a Suggests on haskell-mode which cannot be satisfied on i386.
Package has a Suggests on haskell-mode which cannot be satisfied on armhf.
Package has a Suggests on haskell-mode which cannot be satisfied on arm64.
Package has a Suggests on haskell-mode which cannot be satisfied on amd64.
Package has a Suggests on haskell-mode which cannot be satisfied on ppc64el.


Last updated: Wed Feb 21 15:25:18 2024

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS