Debcheck

 

Back to QA

Debcheck - sid
 Summary
 All packages (light)

main only
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

other
 Depends Main on !Main

all sections
 Broken PreDepends
 Broken Depends
 Broken Recommends
 Broken Suggests

 HalfBroken PreDepends
 HalfBroken Depends
 HalfBroken Recommends
 HalfBroken Suggests

 Build-Depends
 HalfBroken Build-Depends
 Malformed Build-Depends

 OldLibs
 Priority

 Old Standards-Version
 No Standards-Version
 Wrong Standards-Version Syntax

 
   
Distribution: sid buster stretch jessie

Problems for source package thin

Current Source Version: 1.6.3-2
Current Maintainer: Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Section: main
BTS entry: https://bugs.debian.org/src:thin

BuildDepends

Package declares a build time dependency on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on hurd-i386.
Package declares a build time dependency on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on kfreebsd-i386.
Package declares a build time dependency on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on kfreebsd-amd64.

Half Broken Build-Depends

(not necessarily bugs)

Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on hurd-i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on amd64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on mips. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on mips64el. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on armel. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on s390x. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on armhf. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on kfreebsd-i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on arm64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on mipsel. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on kfreebsd-amd64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on ppc64el. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package declares a build time dependency on ruby-rack1.4 which cannot be satisfied on i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.

Binary Package: thin (Version: 1.6.3-2)

BTS entry: https://bugs.debian.org/thin

Relationships

Package has a Depends on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on kfreebsd-i386.
Package has a Depends on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on hurd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on hurd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on hurd-i386.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-i386.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-rack1.4 which cannot be satisfied on hurd-i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on kfreebsd-i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.

Binary Package: thin (Version: 1.6.3-2+b5)

BTS entry: https://bugs.debian.org/thin

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-rack1.4 which cannot be satisfied on s390x. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on armhf. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on amd64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on mips. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on mips64el. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on armel. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on ppc64el. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on i386. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on arm64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.
Package has a Depends on ruby-rack1.4 which cannot be satisfied on mipsel. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.

Binary Package: thin (Version: 1.3.1-5+b5)

BTS entry: https://bugs.debian.org/thin

Relationships

Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-amd64.
Package has a Depends on libruby2.1 (>= 2.1.0) | libruby2.2 (>= 2.2.0~1) which cannot be satisfied on kfreebsd-amd64.
Package has a Depends on ruby-eventmachine (>= 0.12.10) which cannot be satisfied on kfreebsd-amd64.

Half Broken Relationships

(not necessarily bugs)

Package has a Depends on ruby-rack1.4 which cannot be satisfied on kfreebsd-amd64. At least one of ruby-rack (>= 1.0.0) | ruby-rack1.4 can be satisfied however.


Last updated: Thu Dec 13 15:25:15 2018

DO NOT MASS FILE BUG REPORTS
GET A CONSENSUS ON debian-devel@lists.debian.org BEFORE MASS FILING BUGS