Package: form

Scenario: cross_unstable_main_amd64
Date: 2024-03-04 05:00:02

Architectures: armel, armhf

Summary: conflict between libc6-dev:$build and libc6-dev:$host

src:form (4.3.0+git20230104+ds-1) [PTS] [ctrl]
   ↓ build-essential:amd64
build-essential (12.10) [PTS] [ctrl]
   ↓ libc6-dev:amd64 | libc-dev:amd64 | libc-dev:amd64
   ↓ zlib1g-dev
zlib1g-dev (1:1.3.dfsg-3+b1) [PTS] [ctrl]
   ↓ libc6-dev | libc-dev | libc-dev
libc6-dev:$build (2.37-15.1) [PTS] [ctrl]
libc6-dev:$host (2.37-15) [PTS] [ctrl]
CONFLICT

Architectures: mips64el

Summary: conflict between libgcc-s1:$build and libgcc-s1:$host

src:form (4.3.0+git20230104+ds-1) [PTS] [ctrl]
   ↓ build-essential:amd64
build-essential (12.10) [PTS] [ctrl]
   ↓ libc6-dev:amd64 | libc-dev:amd64 | libc-dev:amd64
libc6-dev (2.37-15.1) [PTS] [ctrl]
   ↓ libc6:amd64 (= 2.37-15.1)
libc6 (2.37-15.1) [PTS] [ctrl]
   ↓ libgcc-s1:amd64
   ↓ libgmp-dev
libgmp-dev (2:6.3.0+dfsg-2+b1) [PTS] [ctrl]
   ↓ libgmpxx4ldbl (= 2:6.3.0+dfsg-2+b1)
libgmpxx4ldbl (2:6.3.0+dfsg-2+b1) [PTS] [ctrl]
   ↓ libgcc-s1 (>= 3.0)
libgcc-s1:$build (14-20240303-1) [PTS] [ctrl]
libgcc-s1:$host (14-20240221-2.1) [PTS] [ctrl]
CONFLICT

Architectures: s390x

Summary: conflict between binutils:$host and binutils:$build; conflict between gcc-13:$host and gcc-13:$build; conflict between gcc:$host and gcc:$build

Conjunction of multiple reasons:

  1. src:form (4.3.0+git20230104+ds-1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.15) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.6-5.1) [PTS] [ctrl]
       ↓ gfortran-13 | gfortran-mod-15 | gfortran-mod-15
    gfortran (4:13.2.0-7) [PTS] [ctrl]
       ↓ gcc (= 4:13.2.0-7)
       ↓ build-essential:amd64
    build-essential (12.10) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:12.3)
    gcc:$host (4:13.2.0-7) [PTS] [ctrl]
    gcc:$build (4:13.2.0-7) [PTS] [ctrl]
    CONFLICT
  2. src:form (4.3.0+git20230104+ds-1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.15) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.6-5.1) [PTS] [ctrl]
       ↓ gfortran-13 | gfortran-mod-15 | gfortran-mod-15
    gfortran-9 (9.5.0-5) [PTS] [ctrl]
       ↓ gcc-9 (= 9.5.0-5)
    gcc-9 (9.5.0-5) [PTS] [ctrl]
       ↓ binutils (>= 2.42)
       ↓ debhelper-compat (= 13) | debhelper-compat (= 13)
    debhelper (13.14.1) [PTS] [ctrl]
       ↓ dpkg-dev:amd64 (>= 1.18.2~)
    dpkg-dev (1.22.5) [PTS] [ctrl]
       ↓ binutils:amd64
    binutils:$host (2.42-3) [PTS] [ctrl]
    binutils:$build (2.42-3) [PTS] [ctrl]
    CONFLICT
  3. src:form (4.3.0+git20230104+ds-1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.15) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.6-5.1) [PTS] [ctrl]
       ↓ gfortran-13 | gfortran-mod-15 | gfortran-mod-15
    gfortran-13 (13.2.0-18) [PTS] [ctrl]
       ↓ gcc-13 (= 13.2.0-18)
       ↓ build-essential:amd64
    build-essential (12.10) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:12.3)
    gcc (4:13.2.0-7) [PTS] [ctrl]
       ↓ gcc-13:amd64 (>= 13.2.0-11~)
    gcc-13:$host (13.2.0-18) [PTS] [ctrl]
    gcc-13:$build (13.2.0-18) [PTS] [ctrl]
    CONFLICT