Package: rust-condure

Scenario: cross_unstable_main_amd64
Date: 2022-12-01 05:00:02

Architectures: mips64el

Summary: conflict between g++:$host and g++:$build; conflict between gcc:$host and gcc:$build; conflict between libc6-dev:$host and libc6-dev-mips64el-cross:$build; conflict between libgcc-12-dev-mips64el-cross and libgcc-12-dev-mips64el-cross

Conjunction of multiple reasons:

  1. src:rust-condure (1.6.0-3) [PTS] [ctrl]
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ gcc-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | gcc-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | gcc
       ↓ rustc:amd64
    rustc (1.62.1+dfsg1-1) [PTS] [ctrl]
       ↓ gcc:amd64
    gcc:$host (4:12.2.0-1) [PTS] [ctrl]
    gcc:$build (4:12.2.0-1) [PTS] [ctrl]
    CONFLICT
  2. src:rust-condure (1.6.0-3) [PTS] [ctrl]
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ g++:amd64 (>= 4:10.2)
    g++:$host (4:12.2.0-1) [PTS] [ctrl]
    g++:$build (4:12.2.0-1) [PTS] [ctrl]
    CONFLICT
  3. src:rust-condure (1.6.0-3) [PTS] [ctrl]
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ gcc-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | gcc-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | gcc
    gcc-mips64el-linux-gnuabi64 (4:12.2.0-4) [PTS] [ctrl]
       ↓ gcc-12-mips64el-linux-gnuabi64:amd64 (>= 12.2.0-1~)
    gcc-12-mips64el-linux-gnuabi64 (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libgcc-12-dev-mips64el-cross:amd64 (>= 12.2.0-5cross2)
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++
    g++-mips64el-linux-gnuabi64 (4:12.2.0-4) [PTS] [ctrl]
       ↓ g++-12-mips64el-linux-gnuabi64:amd64 (>= 12.2.0-1~)
    g++-12-mips64el-linux-gnuabi64 (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libstdc++-12-dev-mips64el-cross:amd64 (>= 12)
    libstdc++-12-dev-mips64el-cross (12-20220319-1cross2) [PTS] [ctrl]
       ↓ libgcc-12-dev-mips64el-cross:amd64 (= 12-20220319-1cross2)
    libgcc-12-dev-mips64el-cross (12.2.0-5cross2) [PTS] [ctrl]
    libgcc-12-dev-mips64el-cross (12-20220319-1cross2) [PTS] [ctrl]
    CONFLICT
  4. src:rust-condure (1.6.0-3) [PTS] [ctrl]
       ↓ librust-zmq-0.9+default-dev | librust-zmq-0.9+default-dev
    librust-zmq-dev (0.9.2-2) [PTS] [ctrl]
       ↓ librust-zmq-sys-0.11+default-dev | librust-zmq-sys-0.11+default-dev
    librust-zmq-sys-dev (0.11.0-2) [PTS] [ctrl]
       ↓ libzmq3-dev
    libzmq3-dev (4.3.4-4) [PTS] [ctrl]
       ↓ libnorm-dev
    libnorm-dev (1.5.9+dfsg-2) [PTS] [ctrl]
       ↓ libxml2-dev
    libxml2-dev (2.9.14+dfsg-1.1+b2) [PTS] [ctrl]
       ↓ libicu-dev
    libicu-dev (72.1-3) [PTS] [ctrl]
       ↓ libc6-dev | libc-dev | libc-dev
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++
    g++-mips64el-linux-gnuabi64 (4:12.2.0-4) [PTS] [ctrl]
       ↓ g++-12-mips64el-linux-gnuabi64:amd64 (>= 12.2.0-1~)
    g++-12-mips64el-linux-gnuabi64 (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libstdc++-12-dev-mips64el-cross:amd64 (>= 12)
    libstdc++-12-dev-mips64el-cross (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libc6-dev-mips64el-cross:amd64 (>= 2.23-1~)
    libc6-dev:$host (2.36-6) [PTS] [ctrl]
    libc6-dev-mips64el-cross:$build (2.35-3cross2) [PTS] [ctrl]
    CONFLICT

Architectures: mipsel

Summary: conflict between g++:$host and g++:$build; conflict between libc6-dev:$host and libc6-dev-mipsel-cross:$build

Conjunction of multiple reasons:

  1. src:rust-condure (1.6.0-3) [PTS] [ctrl]
       ↓ crossbuild-essential-mipsel:amd64
    crossbuild-essential-mipsel (12.9) [PTS] [ctrl]
       ↓ g++-mipsel-linux-gnu:amd64 (>= 4:10.2) | g++-mipsel-linux-gnu:amd64 (>= 4:10.2) | g++
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ g++:amd64 (>= 4:10.2)
    g++:$host (4:12.2.0-1) [PTS] [ctrl]
    g++:$build (4:12.2.0-1) [PTS] [ctrl]
    CONFLICT
  2. src:rust-condure (1.6.0-3) [PTS] [ctrl]
       ↓ librust-zmq-0.9+default-dev | librust-zmq-0.9+default-dev
    librust-zmq-dev (0.9.2-2) [PTS] [ctrl]
       ↓ librust-zmq-sys-0.11+default-dev | librust-zmq-sys-0.11+default-dev
    librust-zmq-sys-dev (0.11.0-2) [PTS] [ctrl]
       ↓ libzmq3-dev
    libzmq3-dev (4.3.4-4) [PTS] [ctrl]
       ↓ libnorm-dev
    libnorm-dev (1.5.9+dfsg-2) [PTS] [ctrl]
       ↓ libxml2-dev
    libxml2-dev (2.9.14+dfsg-1.1+b2) [PTS] [ctrl]
       ↓ libicu-dev
    libicu-dev (72.1-3) [PTS] [ctrl]
       ↓ libc6-dev | libc-dev | libc-dev
       ↓ crossbuild-essential-mipsel:amd64
    crossbuild-essential-mipsel (12.9) [PTS] [ctrl]
       ↓ g++-mipsel-linux-gnu:amd64 (>= 4:10.2) | g++-mipsel-linux-gnu:amd64 (>= 4:10.2) | g++
    g++-mipsel-linux-gnu (4:12.2.0-4) [PTS] [ctrl]
       ↓ g++-12-mipsel-linux-gnu:amd64 (>= 12.2.0-1~)
    g++-12-mipsel-linux-gnu (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libstdc++-12-dev-mipsel-cross:amd64 (>= 12)
    libstdc++-12-dev-mipsel-cross (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libc6-dev-mipsel-cross:amd64 (>= 2.23-1~)
    libc6-dev:$host (2.36-6) [PTS] [ctrl]
    libc6-dev-mipsel-cross:$build (2.35-3cross2) [PTS] [ctrl]
    CONFLICT

Architectures: s390x

Summary: conflict between linux-libc-dev:$host and linux-libc-dev:$build

src:rust-condure (1.6.0-3) [PTS] [ctrl]
   ↓ librust-zmq-0.9+default-dev | librust-zmq-0.9+default-dev
librust-zmq-dev (0.9.2-2) [PTS] [ctrl]
   ↓ librust-zmq-sys-0.11+default-dev | librust-zmq-sys-0.11+default-dev
librust-zmq-sys-dev (0.11.0-2) [PTS] [ctrl]
   ↓ libzmq3-dev
libzmq3-dev (4.3.4-4) [PTS] [ctrl]
   ↓ libnorm-dev
libnorm-dev (1.5.9+dfsg-2) [PTS] [ctrl]
   ↓ libxml2-dev
libxml2-dev (2.9.14+dfsg-1.1+b2) [PTS] [ctrl]
   ↓ libicu-dev
libicu-dev (72.1-3) [PTS] [ctrl]
   ↓ libc6-dev | libc-dev | libc-dev
libc6-dev (2.36-6) [PTS] [ctrl]
   ↓ linux-libc-dev
   ↓ rustc:amd64
rustc (1.62.1+dfsg1-1) [PTS] [ctrl]
   ↓ libc-dev:amd64 | libc-dev:amd64
libc6-dev (2.36-6) [PTS] [ctrl]
   ↓ linux-libc-dev:amd64
linux-libc-dev:$host (6.0.10-2) [PTS] [ctrl]
linux-libc-dev:$build (6.0.10-1) [PTS] [ctrl]
CONFLICT