Package: rust-git-absorb

Scenario: cross_unstable_main_amd64
Date: 2022-12-04 05:00:02

Architectures: mips64el

Summary: conflict between g++:$host and g++:$build; conflict between libc6-dev:$host and libc6-dev-mips64el-cross:$build

Conjunction of multiple reasons:

  1. src:rust-git-absorb (0.6.7-1) [PTS] [ctrl]
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ g++:amd64 (>= 4:10.2)
    g++:$host (4:12.2.0-1) [PTS] [ctrl]
    g++:$build (4:12.2.0-1) [PTS] [ctrl]
    CONFLICT
  2. src:rust-git-absorb (0.6.7-1) [PTS] [ctrl]
       ↓ librust-git2-0.14-dev | librust-git2-0.14-dev
    librust-git2-dev (0.14.2-2) [PTS] [ctrl]
       ↓ librust-libgit2-sys-0.13+default-dev (>= 0.13.2-~~) | librust-libgit2-sys-0.13+default-dev (>= 0.13.2-~~)
    librust-libgit2-sys-dev (0.13.2-2) [PTS] [ctrl]
       ↓ libgit2-dev (>= 1.5.0)
    libgit2-dev (1.5.0+ds-6) [PTS] [ctrl]
       ↓ zlib1g-dev
    zlib1g-dev (1:1.2.13.dfsg-1) [PTS] [ctrl]
       ↓ libc6-dev | libc-dev | libc-dev
       ↓ crossbuild-essential-mips64el:amd64
    crossbuild-essential-mips64el (12.9) [PTS] [ctrl]
       ↓ g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++-mips64el-linux-gnuabi64:amd64 (>= 4:10.2) | g++
    g++-mips64el-linux-gnuabi64 (4:12.2.0-4) [PTS] [ctrl]
       ↓ g++-12-mips64el-linux-gnuabi64:amd64 (>= 12.2.0-1~)
    g++-12-mips64el-linux-gnuabi64 (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libstdc++-12-dev-mips64el-cross:amd64 (>= 12)
    libstdc++-12-dev-mips64el-cross (12.2.0-5cross2) [PTS] [ctrl]
       ↓ libc6-dev-mips64el-cross:amd64 (>= 2.23-1~)
    libc6-dev:$host (2.36-6) [PTS] [ctrl]
    libc6-dev-mips64el-cross:$build (2.35-3cross2) [PTS] [ctrl]
    CONFLICT

Architectures: mipsel, s390x

Summary: conflict between libllvm14:$build and libllvm14:$host

src:rust-git-absorb (0.6.7-1) [PTS] [ctrl]
   ↓ rustc:amd64
rustc (1.62.1+dfsg1-1) [PTS] [ctrl]
   ↓ libstd-rust-dev:amd64 (= 1.62.1+dfsg1-1)
libstd-rust-dev (1.62.1+dfsg1-1) [PTS] [ctrl]
   ↓ libstd-rust-1.62:amd64 (= 1.62.1+dfsg1-1)
libstd-rust-1.62 (1.62.1+dfsg1-1) [PTS] [ctrl]
   ↓ libllvm14:amd64
   ↓ libstd-rust-dev
libstd-rust-dev (1.62.1+dfsg1-1) [PTS] [ctrl]
   ↓ libstd-rust-1.62 (= 1.62.1+dfsg1-1)
libstd-rust-1.62 (1.62.1+dfsg1-1) [PTS] [ctrl]
   ↓ libllvm14
libllvm14:$build (1:14.0.6-9) [PTS] [ctrl]
libllvm14:$host (1:14.0.6-8) [PTS] [ctrl]
CONFLICT