Package: sopt

Scenario: cross_unstable_main_amd64
Date: 2021-11-27 05:00:01

Architectures: arm64, armel, ppc64el

Summary: conflict between binutils:$host and binutils:$build; conflict between gcc-11:$host and gcc-11:$build; conflict between gcc:$host and gcc:$build

Conjunction of multiple reasons:

  1. src:sopt (3.0.1-11) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.2~rc1-5) [PTS] [ctrl]
       ↓ gfortran-11 | gfortran-mod-15 | gfortran-mod-15
    gfortran-9 (9.4.0-4) [PTS] [ctrl]
       ↓ gcc-9 (= 9.4.0-4)
    gcc-9 (9.4.0-4) [PTS] [ctrl]
       ↓ binutils (>= 2.37)
       ↓ debhelper-compat (= 13) | debhelper-compat (= 13)
    debhelper (13.5.2) [PTS] [ctrl]
       ↓ dpkg-dev:amd64 (>= 1.18.2~)
    dpkg-dev (1.20.9) [PTS] [ctrl]
       ↓ binutils:amd64
    binutils:$host (2.37-10) [PTS] [ctrl]
    binutils:$build (2.37-10) [PTS] [ctrl]
    CONFLICT
  2. src:sopt (3.0.1-11) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.2~rc1-5) [PTS] [ctrl]
       ↓ gfortran-11 | gfortran-mod-15 | gfortran-mod-15
    gfortran-11 (11.2.0-12) [PTS] [ctrl]
       ↓ gcc-11 (= 11.2.0-12)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc (4:11.2.0-2) [PTS] [ctrl]
       ↓ gcc-11:amd64 (>= 11.2.0-1~)
    gcc-11:$host (11.2.0-12) [PTS] [ctrl]
    gcc-11:$build (11.2.0-12) [PTS] [ctrl]
    CONFLICT
  3. src:sopt (3.0.1-11) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.2~rc1-5) [PTS] [ctrl]
       ↓ gfortran-11 | gfortran-mod-15 | gfortran-mod-15
    gfortran (4:11.2.0-2) [PTS] [ctrl]
       ↓ gcc (= 4:11.2.0-2)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc:$host (4:11.2.0-2) [PTS] [ctrl]
    gcc:$build (4:11.2.0-2) [PTS] [ctrl]
    CONFLICT

Architectures: armhf, s390x

Summary: conflict between binutils:$host and binutils:$build; conflict between gcc-11:$host and gcc-11:$build; conflict between gcc:$host and gcc:$build

Conjunction of multiple reasons:

  1. src:sopt (3.0.1-11) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.2~rc1-5) [PTS] [ctrl]
       ↓ gfortran-11 | gfortran-mod-15 | gfortran-mod-15
    gfortran-11 (11.2.0-12) [PTS] [ctrl]
       ↓ gcc-11 (= 11.2.0-12)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc (4:11.2.0-2) [PTS] [ctrl]
       ↓ gcc-11:amd64 (>= 11.2.0-1~)
    gcc-11:$host (11.2.0-12) [PTS] [ctrl]
    gcc-11:$build (11.2.0-12) [PTS] [ctrl]
    CONFLICT
  2. src:sopt (3.0.1-11) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.2~rc1-5) [PTS] [ctrl]
       ↓ gfortran-11 | gfortran-mod-15 | gfortran-mod-15
    gfortran (4:11.2.0-2) [PTS] [ctrl]
       ↓ gcc (= 4:11.2.0-2)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc:$host (4:11.2.0-2) [PTS] [ctrl]
    gcc:$build (4:11.2.0-2) [PTS] [ctrl]
    CONFLICT
  3. src:sopt (3.0.1-11) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.2~rc1-5) [PTS] [ctrl]
       ↓ gfortran-11 | gfortran-mod-15 | gfortran-mod-15
    gfortran-9 (9.4.0-4) [PTS] [ctrl]
       ↓ gcc-9 (= 9.4.0-4)
    gcc-9 (9.4.0-4) [PTS] [ctrl]
       ↓ binutils (>= 2.37)
       ↓ debhelper-compat (= 13) | debhelper-compat (= 13)
    debhelper (13.5.2) [PTS] [ctrl]
       ↓ dpkg-dev:amd64 (>= 1.18.2~)
    dpkg-dev (1.20.9) [PTS] [ctrl]
       ↓ binutils:amd64
    binutils:$host (2.37-10) [PTS] [ctrl]
    binutils:$build (2.37-10) [PTS] [ctrl]
    CONFLICT

Architectures: mips64el

Summary: conflict between libgcc-s1:$build and libgcc-s1:$host

src:sopt (3.0.1-11) [PTS] [ctrl]
   ↓ libspdlog-dev
libspdlog-dev (1:1.8.5+ds-3) [PTS] [ctrl]
   ↓ libspdlog1 (= 1:1.8.5+ds-3)
libspdlog1 (1:1.8.5+ds-3) [PTS] [ctrl]
   ↓ libgcc-s1 (>= 3.0)
libgcc-s1:$build (11.2.0-12) [PTS] [ctrl]
libgcc-s1:$host (11.2.0-10) [PTS] [ctrl]
CONFLICT

Architectures: mipsel

Summary: conflict between linux-libc-dev:$build and linux-libc-dev:$host

src:sopt (3.0.1-11) [PTS] [ctrl]
   ↓ build-essential:amd64
build-essential (12.9) [PTS] [ctrl]
   ↓ libc6-dev:amd64 | libc-dev:amd64 | libc-dev:amd64
libc6-dev (2.32-4) [PTS] [ctrl]
   ↓ linux-libc-dev:amd64
   ↓ libtiff5-dev
libtiff5-dev (4.3.0-2) [PTS] [ctrl]
   ↓ libtiff-dev (>= 4.0.10-1)
libtiff-dev (4.3.0-2) [PTS] [ctrl]
   ↓ libc6-dev | libc-dev | libc-dev
libc6-dev (2.32-4) [PTS] [ctrl]
   ↓ linux-libc-dev
linux-libc-dev:$build (5.15.5-1) [PTS] [ctrl]
linux-libc-dev:$host (5.15.3-1) [PTS] [ctrl]
CONFLICT