Package: zypper

Scenario: cross_unstable_main_amd64
Date: 2023-01-30 05:00:02

Architectures: arm64, mips64el, mipsel

Summary: conflict between linux-libc-dev:$build and linux-libc-dev:$host

src:zypper (1.14.42-2) [PTS] [ctrl]
   ↓ build-essential:amd64
build-essential (12.9) [PTS] [ctrl]
   ↓ libc6-dev:amd64 | libc-dev:amd64 | libc-dev:amd64
libc6-dev (2.36-8) [PTS] [ctrl]
   ↓ linux-libc-dev:amd64
   ↓ libzypp-dev (>= 17.25)
libzypp-dev (17.25.7-2.3) [PTS] [ctrl]
   ↓ libpopt-dev
libpopt-dev (1.19+dfsg-1) [PTS] [ctrl]
   ↓ libc6-dev | libc-dev | libc-dev
libc6-dev (2.36-8) [PTS] [ctrl]
   ↓ linux-libc-dev
linux-libc-dev:$build (6.1.8-1) [PTS] [ctrl]
linux-libc-dev:$host (6.1.7-1) [PTS] [ctrl]
CONFLICT

Architectures: armel

Summary: conflict between binutils:$host and binutils:$build; conflict between gcc-12:$host and gcc-12:$build; conflict between gcc:$host and gcc:$build

Conjunction of multiple reasons:

  1. src:zypper (1.14.42-2) [PTS] [ctrl]
       ↓ libboost-all-dev
    libboost-all-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi-dev
    libboost-mpi-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi1.74-dev
    libboost-mpi1.74-dev (1.74.0-18.1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.14) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.4-3) [PTS] [ctrl]
       ↓ gfortran-12 | gfortran-mod-15 | gfortran-mod-15
    gfortran-12 (12.2.0-14) [PTS] [ctrl]
       ↓ gcc-12 (= 12.2.0-14)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc (4:12.2.0-3) [PTS] [ctrl]
       ↓ gcc-12:amd64 (>= 12.2.0-1~)
    gcc-12:$host (12.2.0-14) [PTS] [ctrl]
    gcc-12:$build (12.2.0-14) [PTS] [ctrl]
    CONFLICT
  2. src:zypper (1.14.42-2) [PTS] [ctrl]
       ↓ libboost-all-dev
    libboost-all-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi-dev
    libboost-mpi-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi1.74-dev
    libboost-mpi1.74-dev (1.74.0-18.1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.14) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.4-3) [PTS] [ctrl]
       ↓ gfortran-12 | gfortran-mod-15 | gfortran-mod-15
    gfortran-9 (9.5.0-2+b3) [PTS] [ctrl]
       ↓ gcc-9 (= 9.5.0-2+b3)
    gcc-9 (9.5.0-2+b3) [PTS] [ctrl]
       ↓ binutils (>= 2.39.50.20221224)
       ↓ debhelper (>= 10~)
    debhelper (13.11.4) [PTS] [ctrl]
       ↓ dpkg-dev:amd64 (>= 1.18.2~)
    dpkg-dev (1.21.19) [PTS] [ctrl]
       ↓ binutils:amd64
    binutils:$host (2.40-2) [PTS] [ctrl]
    binutils:$build (2.40-2) [PTS] [ctrl]
    CONFLICT
  3. src:zypper (1.14.42-2) [PTS] [ctrl]
       ↓ libboost-all-dev
    libboost-all-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi-dev
    libboost-mpi-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi1.74-dev
    libboost-mpi1.74-dev (1.74.0-18.1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.14) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.4-3) [PTS] [ctrl]
       ↓ gfortran-12 | gfortran-mod-15 | gfortran-mod-15
    gfortran (4:12.2.0-3) [PTS] [ctrl]
       ↓ gcc (= 4:12.2.0-3)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc:$host (4:12.2.0-3) [PTS] [ctrl]
    gcc:$build (4:12.2.0-3) [PTS] [ctrl]
    CONFLICT

Architectures: armhf

Summary: conflict between binutils:$host and binutils:$build; conflict between gcc-12:$host and gcc-12:$build; conflict between gcc:$host and gcc:$build

Conjunction of multiple reasons:

  1. src:zypper (1.14.42-2) [PTS] [ctrl]
       ↓ libboost-all-dev
    libboost-all-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi-dev
    libboost-mpi-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi1.74-dev
    libboost-mpi1.74-dev (1.74.0-18.1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.14) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.4-3) [PTS] [ctrl]
       ↓ gfortran-12 | gfortran-mod-15 | gfortran-mod-15
    gfortran (4:12.2.0-3) [PTS] [ctrl]
       ↓ gcc (= 4:12.2.0-3)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc:$host (4:12.2.0-3) [PTS] [ctrl]
    gcc:$build (4:12.2.0-3) [PTS] [ctrl]
    CONFLICT
  2. src:zypper (1.14.42-2) [PTS] [ctrl]
       ↓ libboost-all-dev
    libboost-all-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi-dev
    libboost-mpi-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi1.74-dev
    libboost-mpi1.74-dev (1.74.0-18.1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.14) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.4-3) [PTS] [ctrl]
       ↓ gfortran-12 | gfortran-mod-15 | gfortran-mod-15
    gfortran-12 (12.2.0-14) [PTS] [ctrl]
       ↓ gcc-12 (= 12.2.0-14)
       ↓ build-essential:amd64
    build-essential (12.9) [PTS] [ctrl]
       ↓ gcc:amd64 (>= 4:10.2)
    gcc (4:12.2.0-3) [PTS] [ctrl]
       ↓ gcc-12:amd64 (>= 12.2.0-1~)
    gcc-12:$host (12.2.0-14) [PTS] [ctrl]
    gcc-12:$build (12.2.0-14) [PTS] [ctrl]
    CONFLICT
  3. src:zypper (1.14.42-2) [PTS] [ctrl]
       ↓ libboost-all-dev
    libboost-all-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi-dev
    libboost-mpi-dev (1.74.0.3) [PTS] [ctrl]
       ↓ libboost-mpi1.74-dev
    libboost-mpi1.74-dev (1.74.0-18.1) [PTS] [ctrl]
       ↓ mpi-default-dev
    mpi-default-dev (1.14) [PTS] [ctrl]
       ↓ libopenmpi-dev
    libopenmpi-dev (4.1.4-3) [PTS] [ctrl]
       ↓ gfortran-12 | gfortran-mod-15 | gfortran-mod-15
    gfortran-9 (9.5.0-2+b3) [PTS] [ctrl]
       ↓ gcc-9 (= 9.5.0-2+b3)
    gcc-9 (9.5.0-2+b3) [PTS] [ctrl]
       ↓ binutils (>= 2.39.50.20221224)
       ↓ debhelper (>= 10~)
    debhelper (13.11.4) [PTS] [ctrl]
       ↓ dpkg-dev:amd64 (>= 1.18.2~)
    dpkg-dev (1.21.19) [PTS] [ctrl]
       ↓ binutils:amd64
    binutils:$host (2.40-2) [PTS] [ctrl]
    binutils:$build (2.40-2) [PTS] [ctrl]
    CONFLICT

Architectures: ppc64el

Summary: conflict between libbsd0:$build and libbsd0:$host

src:zypper (1.14.42-2) [PTS] [ctrl]
   ↓ asciidoctor
asciidoctor (2.0.18-1) [PTS] [ctrl]
   ↓ ruby-asciidoctor:amd64 (>= 2.0.18-1)
ruby-asciidoctor (2.0.18-1) [PTS] [ctrl]
   ↓ ruby:amd64
ruby (1:3.1) [PTS] [ctrl]
   ↓ ruby3.1:amd64
ruby3.1 (3.1.2-6) [PTS] [ctrl]
   ↓ libruby3.1:amd64 (>= 3.1.0~preview1)
libruby3.1 (3.1.2-6) [PTS] [ctrl]
   ↓ libedit2:amd64 (>= 3.1-20221030-2)
libedit2 (3.1-20221030-2) [PTS] [ctrl]
   ↓ libbsd0:amd64 (>= 0.1.3)
   ↓ libboost-all-dev
libboost-all-dev (1.74.0.3) [PTS] [ctrl]
   ↓ libboost-mpi-python-dev
libboost-mpi-python-dev (1.74.0.3) [PTS] [ctrl]
   ↓ libboost-mpi-python1.74-dev
libboost-mpi-python1.74-dev (1.74.0-18.1) [PTS] [ctrl]
   ↓ libboost-mpi-python1.74.0 (= 1.74.0-18.1)
libboost-mpi-python1.74.0 (1.74.0-18.1) [PTS] [ctrl]
   ↓ libopenmpi3 (>= 4.1.4)
libopenmpi3 (4.1.4-3) [PTS] [ctrl]
   ↓ libhwloc-plugins
libhwloc-plugins (2.9.0-1) [PTS] [ctrl]
   ↓ libx11-6
libx11-6 (2:1.8.3-3) [PTS] [ctrl]
   ↓ libxcb1 (>= 1.11.1)
libxcb1 (1.15-1) [PTS] [ctrl]
   ↓ libxdmcp6
libxdmcp6 (1:1.1.2-3) [PTS] [ctrl]
   ↓ libbsd0 (>= 0.2.0)
libbsd0:$build (0.11.7-2) [PTS] [ctrl]
libbsd0:$host (0.11.7-1) [PTS] [ctrl]
CONFLICT