libretro-beetle-pce-fast (0.9.38.7+git20160609-2) [PTS] [DDPO]

OK: VCS matches the version in the archive

Package: [Main page]